summaryrefslogtreecommitdiff
path: root/app-text/libmwaw
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
commitf4fc10428424904caf2035cffc442195cb088b2c (patch)
tree72f320d5963e55586cfdeed2b14c72b8191b6327 /app-text/libmwaw
parentfbd9734cedfe790955100b8e4ab3613457d77b1a (diff)
gentoo resync : 28.07.2021
Diffstat (limited to 'app-text/libmwaw')
-rw-r--r--app-text/libmwaw/Manifest4
-rw-r--r--app-text/libmwaw/libmwaw-0.3.20.ebuild51
-rw-r--r--app-text/libmwaw/libmwaw-9999.ebuild19
3 files changed, 63 insertions, 11 deletions
diff --git a/app-text/libmwaw/Manifest b/app-text/libmwaw/Manifest
index f268cc863a7f..aff1e9d3f77b 100644
--- a/app-text/libmwaw/Manifest
+++ b/app-text/libmwaw/Manifest
@@ -1,4 +1,6 @@
DIST libmwaw-0.3.19.tar.xz 1401720 BLAKE2B 93e63993dd73d52d1b071c44a5efa4ba2495a370a767cd80fbeb437a56224d333781cfdf32c3ca1c0a3794544da6cdf8c967badf98b6858796fbc8f2ea7878c1 SHA512 a5b74f417366f7e8a8303948e678d54caf9c45e0b51694d39593926b2f2fbbaa5dfea5dee8a6b4a656e5ca5bd880f41a76e7b869f55230690740b7ab75a28f1f
+DIST libmwaw-0.3.20.tar.xz 1425812 BLAKE2B a708ce4a28a0d5a5a5ee9d178c67119189add0180e61d67af6821c509d95b9f8bfb60eeb1afcdf8e2da5bed26053108b12db57db98912d97dc7e0ef0f7121f18 SHA512 d6cd28629b6482dd61e070036e94568ecc44d9064dddd9c699c7362caa8ef36652ce84cf0f199813854636f2e39ab19d47f4e148990822791b88cd3f17f68b3b
EBUILD libmwaw-0.3.19.ebuild 1004 BLAKE2B e6db19e89201be0df73cb6dd3deb81eaf2e08d442c6d958826e95120d14ce2740248158b3a1f5084ae4b9f588d22d62c4794f090f0c58aebcde48204ea256560 SHA512 2ba0bc30818fc9b4032698081bcdea307185e24dd08885168d05ca6ab43bbb6dd2747cfa2268a5416e31c4050fcada5bfcb32bf605d4eadba26cf766b407a2f4
-EBUILD libmwaw-9999.ebuild 1007 BLAKE2B 0d5cee2920040a56940cf0e916f4734433875c73fe541d7918c3bdaea0d4820a40975a0d67c154ef23a02f6b70e3fe49b9ceaaacc79cfd82c6ee74d552f455e4 SHA512 d65054c2dbd389041d5c55bfa8f8819507987ef862474f218ba6115d818dda293ecc7473f67b33cdd89679f706a7b2d717e22f6c071e922d79aeea1a37917a16
+EBUILD libmwaw-0.3.20.ebuild 993 BLAKE2B 67267f5263a9c98540db6033727d6276f9c033265d1afe2dcde1a9918ff3181ca2b8ae34ec96ffdd9ef0027cb8523ed54f9550dcdf86eaffa5af6c036793ec12 SHA512 dcdcefdb014c8a08ba5415fe53674371f0255fc49c8a070ffd2047b164b7083c280dd039287ba48c3b3be5e68f7cda543ea33e7ec53d1784041c7346c76519ba
+EBUILD libmwaw-9999.ebuild 993 BLAKE2B 67267f5263a9c98540db6033727d6276f9c033265d1afe2dcde1a9918ff3181ca2b8ae34ec96ffdd9ef0027cb8523ed54f9550dcdf86eaffa5af6c036793ec12 SHA512 dcdcefdb014c8a08ba5415fe53674371f0255fc49c8a070ffd2047b164b7083c280dd039287ba48c3b3be5e68f7cda543ea33e7ec53d1784041c7346c76519ba
MISC metadata.xml 403 BLAKE2B cbddacc98e4f22e521d739150ee4044b93c297dbd6d220a445192a3d1a6316491d6ed72ada8bd138c287133fcaf1b3d5ce580e68dd3ec071d36abbc1b05b4b6d SHA512 12cebd7bdaff6a793598f40cb11f4ae6681dcb29b18ecb7db92681abf1f6d4ce0281ae292c84106a143c0ff5ff3395e37604b3576c6a479001fc351dba10c7ed
diff --git a/app-text/libmwaw/libmwaw-0.3.20.ebuild b/app-text/libmwaw/libmwaw-0.3.20.ebuild
new file mode 100644
index 000000000000..f0bf404e1fb2
--- /dev/null
+++ b/app-text/libmwaw/libmwaw-0.3.20.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/libmwaw/libmwaw"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Library parsing many pre-OSX MAC text formats"
+HOMEPAGE="https://sourceforge.net/p/libmwaw/wiki/Home/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc tools"
+
+DEPEND="
+ dev-libs/librevenge
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999* ]] && eautoreconf
+}
+
+src_configure() {
+ # zip is hard enabled as the zlib is dep on the rdeps anyway
+ local myeconfargs=(
+ --enable-zip
+ --disable-werror
+ $(use_with doc docs)
+ $(use_enable tools)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}
diff --git a/app-text/libmwaw/libmwaw-9999.ebuild b/app-text/libmwaw/libmwaw-9999.ebuild
index bd259959df53..f0bf404e1fb2 100644
--- a/app-text/libmwaw/libmwaw-9999.ebuild
+++ b/app-text/libmwaw/libmwaw-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-if [[ ${PV} = 9999 ]]; then
+if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://git.code.sf.net/p/libmwaw/libmwaw"
inherit autotools git-r3
else
@@ -18,27 +18,26 @@ LICENSE="LGPL-2.1"
SLOT="0"
IUSE="doc tools"
-BDEPEND="
- sys-devel/libtool
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
-"
DEPEND="
dev-libs/librevenge
sys-libs/zlib
"
RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
src_prepare() {
default
- [[ ${PV} == 9999 ]] && eautoreconf
+ [[ ${PV} == *9999* ]] && eautoreconf
}
src_configure() {
# zip is hard enabled as the zlib is dep on the rdeps anyway
local myeconfargs=(
--enable-zip
- --disable-static
--disable-werror
$(use_with doc docs)
$(use_enable tools)