summaryrefslogtreecommitdiff
path: root/app-text/libmspub
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/libmspub
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/libmspub')
-rw-r--r--app-text/libmspub/Manifest6
-rw-r--r--app-text/libmspub/libmspub-0.1.2.ebuild55
-rw-r--r--app-text/libmspub/libmspub-0.1.4.ebuild55
-rw-r--r--app-text/libmspub/libmspub-9999.ebuild55
-rw-r--r--app-text/libmspub/metadata.xml8
5 files changed, 179 insertions, 0 deletions
diff --git a/app-text/libmspub/Manifest b/app-text/libmspub/Manifest
new file mode 100644
index 000000000000..1254005f5a46
--- /dev/null
+++ b/app-text/libmspub/Manifest
@@ -0,0 +1,6 @@
+DIST libmspub-0.1.2.tar.xz 345556 BLAKE2B a3b47fb188fc859abf54e3375514d31a1fafa21fb57fe0ac4a20013741a223a7011adf8ce7784b61346b49e9f4c0b6c353138dc12a5035f7bcc24576a508aa50 SHA512 c19025a2b887c33f5966b0972204ab2a8ae841b82df38eaf53c0cdc8f99d93cccab5e1c78143a79d5aef9c7a7387bd6f2cf34833a00861058e0e4687f48be714
+DIST libmspub-0.1.4.tar.xz 377472 BLAKE2B 89bd994a5aa2b3a22681dfe78fcea19561ea6057210e61630fa904ded12cca4694d715dd8f2fe8f687a91951bfa2f7aec1ff11d0b978a517476545bb07f654dd SHA512 7275f890645961b3fd56df4584788962e8c064fe3f99f5834c6ba6177ce76d00d544fbe9a25b7ab2f4180d2f3a90c609fe0bb68d61ea24e95b086190390fff31
+EBUILD libmspub-0.1.2.ebuild 1167 BLAKE2B 41b323d700a9a2096a7b5f265df9d6511605b8bc0940f0ef47380a27125ae07f32deac57dad92ace14beebe211cea81b1350e5a74d866fe9ef826dda69d8552e SHA512 523d3d1660341335b2b5e6995c84e794bff2920f18ba2cd36400ffdeb69c83718c42296422527e225cef9e6b86ad6dea1f613947936c7601aaee429d0bb8252f
+EBUILD libmspub-0.1.4.ebuild 1168 BLAKE2B fff7ee4af9526add5ef82bb18ff471b0914737760f0bd93f3642c5f636ca9ce3196ae3084f1f3e85b13f71b8beeb592bd425b89a755f633c39be9e168315302e SHA512 1ca54c51d7e88b9f65a615cc2c25e52ca62711e09f297c7fe11021c1ee37380a790d2f04af01b6ee9b19dab3d216e6ec876553a4a68d57fecb5170924abd9328
+EBUILD libmspub-9999.ebuild 1171 BLAKE2B b9df1f08071dfb36cd24e62e3e6e120b47c7f3a252a5921533357706a5eda7139e3f6e8720d6401c3259bd941ba326ac044de2772cb8a5bd86c86453d1f110ee SHA512 c6b9f035c794632f6e4ba273ea8ec31d23dc3067ba531bb4365ec6b945039b7ea59ab1f3e89934f3d2600b2b9147d6cc4889a858561e350accab32219e9afad3
+MISC metadata.xml 255 BLAKE2B 9b8486730bea2158e8be5cbbe0552c5460d1b18e2236a68e3f11d85ce4eeb96eb0e746f44a10cb7cdcf1bf498190a512ef42f47852c6843b9a3c937ceabc338d SHA512 ac646e8ac676faf0aac283e4be31c5f2b29e98ccf07327073ed05e688ce696caf639bdfea63e4aed141a90e84c0a86892bc717a52b95cdf1739aaa15240013c3
diff --git a/app-text/libmspub/libmspub-0.1.2.ebuild b/app-text/libmspub/libmspub-0.1.2.ebuild
new file mode 100644
index 000000000000..16c01c8e0026
--- /dev/null
+++ b/app-text/libmspub/libmspub-0.1.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libmspub.git"
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="Library parsing Microsoft Publisher documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libmspub"
+[[ ${PV} == 9999 ]] || SRC_URI="https://dev-www.libreoffice.org/src/libmspub/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ppc ppc64 x86"
+
+IUSE="doc static-libs"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/librevenge
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ default
+ [[ -d m4 ]] || mkdir "m4"
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ # bug 619044
+ append-cxxflags -std=c++14
+
+ econf \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/app-text/libmspub/libmspub-0.1.4.ebuild b/app-text/libmspub/libmspub-0.1.4.ebuild
new file mode 100644
index 000000000000..f881fb03dafb
--- /dev/null
+++ b/app-text/libmspub/libmspub-0.1.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libmspub.git"
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="Library parsing Microsoft Publisher documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libmspub"
+[[ ${PV} == 9999 ]] || SRC_URI="https://dev-www.libreoffice.org/src/libmspub/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ppc64 x86"
+
+IUSE="doc static-libs"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/librevenge
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ default
+ [[ -d m4 ]] || mkdir "m4"
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ # bug 619044
+ append-cxxflags -std=c++14
+
+ econf \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/app-text/libmspub/libmspub-9999.ebuild b/app-text/libmspub/libmspub-9999.ebuild
new file mode 100644
index 000000000000..c627cd0bee6f
--- /dev/null
+++ b/app-text/libmspub/libmspub-9999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libmspub.git"
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="Library parsing Microsoft Publisher documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libmspub"
+[[ ${PV} == 9999 ]] || SRC_URI="https://dev-www.libreoffice.org/src/libmspub/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+
+IUSE="doc static-libs"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/librevenge
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ default
+ [[ -d m4 ]] || mkdir "m4"
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ # bug 619044
+ append-cxxflags -std=c++14
+
+ econf \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/app-text/libmspub/metadata.xml b/app-text/libmspub/metadata.xml
new file mode 100644
index 000000000000..13ce236ee519
--- /dev/null
+++ b/app-text/libmspub/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>office@gentoo.org</email>
+ <name>Gentoo Office project</name>
+ </maintainer>
+</pkgmetadata>