summaryrefslogtreecommitdiff
path: root/app-text/libgepub/libgepub-0.5.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/libgepub/libgepub-0.5.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/libgepub/libgepub-0.5.2.ebuild')
-rw-r--r--app-text/libgepub/libgepub-0.5.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-text/libgepub/libgepub-0.5.2.ebuild b/app-text/libgepub/libgepub-0.5.2.ebuild
new file mode 100644
index 000000000000..37ff044fb87c
--- /dev/null
+++ b/app-text/libgepub/libgepub-0.5.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome.org meson
+
+DESCRIPTION="GObject based library for handling and rendering epub documents"
+HOMEPAGE="https://git.gnome.org/browse/libgepub"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection"
+
+RDEPEND="
+ app-arch/libarchive
+ dev-libs/glib:2
+ dev-libs/libxml2
+ net-libs/libsoup:2.4
+ net-libs/webkit-gtk:4
+ x11-libs/gtk+:3
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ meson_src_configure \
+ -Denable-introspection=$(usex introspection true false)
+}