summaryrefslogtreecommitdiff
path: root/app-text/libexttextcat/libexttextcat-3.4.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/libexttextcat/libexttextcat-3.4.5.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/libexttextcat/libexttextcat-3.4.5.ebuild')
-rw-r--r--app-text/libexttextcat/libexttextcat-3.4.5.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-text/libexttextcat/libexttextcat-3.4.5.ebuild b/app-text/libexttextcat/libexttextcat-3.4.5.ebuild
new file mode 100644
index 000000000000..e48b3a9a6156
--- /dev/null
+++ b/app-text/libexttextcat/libexttextcat-3.4.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Library implementing N-gram-based text categorization"
+HOMEPAGE="http://software.wise-guys.nl/libtextcat/"
+SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}