summaryrefslogtreecommitdiff
path: root/app-text/libepubgen
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/libepubgen
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/libepubgen')
-rw-r--r--app-text/libepubgen/Manifest5
-rw-r--r--app-text/libepubgen/libepubgen-0.1.0.ebuild40
-rw-r--r--app-text/libepubgen/libepubgen-0.1.1.ebuild39
-rw-r--r--app-text/libepubgen/metadata.xml8
4 files changed, 92 insertions, 0 deletions
diff --git a/app-text/libepubgen/Manifest b/app-text/libepubgen/Manifest
new file mode 100644
index 000000000000..e197d4d5107c
--- /dev/null
+++ b/app-text/libepubgen/Manifest
@@ -0,0 +1,5 @@
+DIST libepubgen-0.1.0.tar.xz 319652 BLAKE2B e6573e0a680711380ac3d2ef742413e38030e76dc50639f9659544e7410f7d7f987cdf1aa20cf2f2afa924bbcbecaf7141225d387fc509d0db6387cd144cb16e SHA512 6be431d06321807991048567aebd7111359f8aa364fe33e651c991553f832c03ad3bb3520b9f7e8d72a861a9ebd84483587becb9062e226bcd1d8ade1819b4a9
+DIST libepubgen-0.1.1.tar.xz 324380 BLAKE2B f2dd4ee4987aa69f3972f83fe6348e8f0d4ba2d5c2f8f871e81d7e9dd5dcc00e10fc2be27fcbbb6170f5a673b86c62261fb8d25ff3bf788cda726e64a254ec7d SHA512 9d911384672b5394ff1df3280a5c9fe12888530c41f177aa100f135954e2ec279b64193f8388f12c96f6a6e587483ce853e74fe45b29fb748a930512dd011c2b
+EBUILD libepubgen-0.1.0.ebuild 725 BLAKE2B df6c45b50db98bc979374adead89de3e2cb5d7a055b298d6538ce2dea44790b201cef4b437e1af86755ea3bae0c7cd6f8eb4de27f3c610e6db78df4ebf497f4d SHA512 8de1cf0aa61451aa11703e3dadb1fb00a03e3945f4ed2dfb8b4e7fa96f28fd0da2d14124f45e71b5868c72bf62e7488cd63785a4f68c652df618b15f25d43691
+EBUILD libepubgen-0.1.1.ebuild 713 BLAKE2B 57119868a143aa90b78c9e82339fa108e2cdf988220626a759459bbfa084d3ac9dca2a93af3488d9f2409a79e4876e75bc1cd0ac075df00c8aa291ad26c965a4 SHA512 7372214a9bd3f0576c5a23cde82b528dbcd9d16e2d2a3cfcf439052282da13b8e9eb03e7aea97b514c2fcd013a8574ae53c38ee0828d39c8a386642cedd319c7
+MISC metadata.xml 255 BLAKE2B 9b8486730bea2158e8be5cbbe0552c5460d1b18e2236a68e3f11d85ce4eeb96eb0e746f44a10cb7cdcf1bf498190a512ef42f47852c6843b9a3c937ceabc338d SHA512 ac646e8ac676faf0aac283e4be31c5f2b29e98ccf07327073ed05e688ce696caf639bdfea63e4aed141a90e84c0a86892bc717a52b95cdf1739aaa15240013c3
diff --git a/app-text/libepubgen/libepubgen-0.1.0.ebuild b/app-text/libepubgen/libepubgen-0.1.0.ebuild
new file mode 100644
index 000000000000..300033a02b9b
--- /dev/null
+++ b/app-text/libepubgen/libepubgen-0.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="EPUB generator for librevenge"
+HOMEPAGE="https://sourceforge.net/projects/libepubgen/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="debug doc test"
+
+RDEPEND="
+ dev-libs/librevenge
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? (
+ dev-util/cppunit
+ dev-libs/libxml2:2
+ )
+"
+
+src_configure() {
+ econf \
+ --disable-weffc \
+ --disable-werror \
+ $(use_enable debug) \
+ $(use_with doc docs) \
+ $(use_enable test tests)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/app-text/libepubgen/libepubgen-0.1.1.ebuild b/app-text/libepubgen/libepubgen-0.1.1.ebuild
new file mode 100644
index 000000000000..80387cdb8ac9
--- /dev/null
+++ b/app-text/libepubgen/libepubgen-0.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="EPUB generator for librevenge"
+HOMEPAGE="https://sourceforge.net/projects/libepubgen/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="debug doc test"
+
+RDEPEND="
+ dev-libs/librevenge
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? (
+ dev-util/cppunit
+ dev-libs/libxml2:2
+ )
+"
+
+src_configure() {
+ econf \
+ --disable-weffc \
+ $(use_enable debug) \
+ $(use_with doc docs) \
+ $(use_enable test tests)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/app-text/libepubgen/metadata.xml b/app-text/libepubgen/metadata.xml
new file mode 100644
index 000000000000..13ce236ee519
--- /dev/null
+++ b/app-text/libepubgen/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>office@gentoo.org</email>
+ <name>Gentoo Office project</name>
+ </maintainer>
+</pkgmetadata>