summaryrefslogtreecommitdiff
path: root/app-text/libebook/libebook-0.1.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/libebook/libebook-0.1.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/libebook/libebook-0.1.2-r1.ebuild')
-rw-r--r--app-text/libebook/libebook-0.1.2-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-text/libebook/libebook-0.1.2-r1.ebuild b/app-text/libebook/libebook-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..53975fc2cc1e
--- /dev/null
+++ b/app-text/libebook/libebook-0.1.2-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="libe-book"
+MY_P="${MY_PN}-${PV}"
+
+inherit autotools
+
+DESCRIPTION="Library parsing various ebook formats"
+HOMEPAGE="http://www.sourceforge.net/projects/libebook/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 x86"
+IUSE="doc test tools"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/librevenge
+ dev-libs/libxml2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ dev-util/gperf
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+RDEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-boost-1.59-makefile.patch"
+ "${FILESDIR}/${P}-tests.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_enable test tests) \
+ $(use_with tools)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}