summaryrefslogtreecommitdiff
path: root/app-text/lesspipe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /app-text/lesspipe
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'app-text/lesspipe')
-rw-r--r--app-text/lesspipe/Manifest2
-rw-r--r--app-text/lesspipe/lesspipe-1.84.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/app-text/lesspipe/Manifest b/app-text/lesspipe/Manifest
index 6a432ce0dd03..dbc92853cad4 100644
--- a/app-text/lesspipe/Manifest
+++ b/app-text/lesspipe/Manifest
@@ -1,4 +1,6 @@
DIST lesspipe-1.83.tar.gz 115129 BLAKE2B 24d9e4a226537a44c01c316528e085c6d2d7889b2ae5166d70b85e12c5f0b34e825e039a70071d7e75947e1c63d527decb21973631e910de42c75ec3ee17436c SHA512 c6418ac2bfc2dee9d32d56b0ea4a94954b1431db54fef8b67a9cf7d961cf4a23d87b2f41b2a4560d2333029c6d4ed5c6f399cb635f857bd43f1603993b5cb55d
+DIST lesspipe-1.84.tar.gz 119657 BLAKE2B 671b504022bdba82eea03d7a83960d5ed148d851d0420f179967f46d38a88ab90c9928a462e01744134aedfe710dba741430e78743451b1b65e603e5d89ae139 SHA512 f11ef23610f722d62ddf7e084b03967ed59d21af6ac207d4456f625c93c3c58c87ec5907cf6bca00ae5550dcddfc9b7f0be5de51f9ff81044fcff1f1cde81267
EBUILD lesspipe-1.83-r1.ebuild 1123 BLAKE2B e0e9a8373bda948281b5a584b174bb9bd1b75b503f004fdbaec54629673cbb7a850a685445dbd7de9b3bc1237f052fdb10e8ee771d3600c5fee4f2cfcacfc5b7 SHA512 334fae62576add56f38a0ba9c0ff46bdba7a5bf03a5f5236e028b30ee3cadc123913aae4d78ef38942d7b816e2f243cdb6828c7a366313ff83f48cc82e92fddd
EBUILD lesspipe-1.83.ebuild 1136 BLAKE2B 4e7dd1ab4b3a24c1233539d1132b791b5576eb81c32fc866bfaabe3904c9de104e02db88a516f122f5892a08c9da231100c1417a55536973b241751bd55fdbd9 SHA512 aa8ed4b60d7396c65204d149057ac8f56480201ac1fccca2d9f5661a76100cdca8daf2c322dfe9d3e754281c49d5ec6b07201b938e72e96e72f2a1f4212f205d
+EBUILD lesspipe-1.84.ebuild 1129 BLAKE2B c0e0e5bc2bf7412601c6c79a98fa044e7754b16fdea7620749c0468d1b8004e7ff8864ca1116e2cc26cdc575b1286415d6808964a246f981057b44e184926028 SHA512 1c827e596d3915ec72de0d72397005c6daf0ed80e691d26593c2e536a1e1de1f66dd73c7ed903402fbebb8607e57a3e652a1e3cd4dcce6b43992e0e2a3fc142d
MISC metadata.xml 303 BLAKE2B 57a0ab69188055eec0a29d4f2e331dd027d87b12623099013f889cd4954574772f3279c7fdce85c0fe627083db59a89a6d3daed8266c867b17bbdf84d1fef4a5 SHA512 efdd1963073db285de7f83ff804fdc98876846cb011fa0c8aa65f9b3c1dd6b7cdb039ca6a7a03018edfdff930f817208bb29601bb0c5571fc16d637615e0c7b7
diff --git a/app-text/lesspipe/lesspipe-1.84.ebuild b/app-text/lesspipe/lesspipe-1.84.ebuild
new file mode 100644
index 000000000000..4ecd47310905
--- /dev/null
+++ b/app-text/lesspipe/lesspipe-1.84.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="a preprocessor for less"
+HOMEPAGE="https://github.com/wofr06/lesspipe"
+SRC_URI="https://github.com/wofr06/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ !<sys-apps/less-483-r1"
+
+src_configure() {
+ # Not an autoconf script.
+ ./configure --fixed || die
+}
+
+src_compile() {
+ # Nothing to build.
+ :
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install
+ einstalldocs
+}
+
+pkg_preinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "This package installs 'lesspipe.sh' which is distinct from 'lesspipe'."
+ elog "The latter is the Gentoo-specific version. Make sure to update your"
+ elog "LESSOPEN environment variable if you wish to use this copy."
+ fi
+}