summaryrefslogtreecommitdiff
path: root/app-text/lesspipe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-18 08:34:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-18 08:34:08 +0100
commit933ed80ab9b645de54b16eeb7410c0a54f47574f (patch)
treed954e8a97c73506c33035766b9578ece5d31667f /app-text/lesspipe
parent0b1a4d018ed7758b9e49f6e4b3b38304f91a8cf5 (diff)
gentoo auto-resync : 18:08:2022 - 08:34:07
Diffstat (limited to 'app-text/lesspipe')
-rw-r--r--app-text/lesspipe/Manifest2
-rw-r--r--app-text/lesspipe/lesspipe-2.06.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/app-text/lesspipe/Manifest b/app-text/lesspipe/Manifest
index 3a54592dd637..a067009beef8 100644
--- a/app-text/lesspipe/Manifest
+++ b/app-text/lesspipe/Manifest
@@ -1,3 +1,5 @@
DIST lesspipe-2.05.tar.gz 167135 BLAKE2B 6f54a68a3857fcafa19148ba798d6ac49b2693e547e88a4a4fb6a178768d75ba8ae08e808a9e08aabfe903538bd401e3bd25e22ec240bf3a52365df729d87b9e SHA512 b4220b28fb609060735663067f5a738cae32d12e90efc397db3749e4dcfa7bfc063a4458c1f39b8a43be3b04effdc00a25c4feebd6e9a3b23f0064b879bbb698
+DIST lesspipe-2.06.tar.gz 168100 BLAKE2B a7447efa85cd422343f9dbb06001e85fa7b33c92db752f8248e4b4a0d9ecce4ef0241240d6993c5a71157c44da2f4ffc3efd41ac5e0a31e89ed5b80ac99f71fe SHA512 b2411c5e6b287fb67e1ea9b6d10377fe19b58e8c0f54587f825d1ee4c1a85f9a8ed3244a7cf339bcba960094e95821d9a56929951d862eb697f1d12fe55ef20d
EBUILD lesspipe-2.05.ebuild 1239 BLAKE2B 2265355eb134120872f08556c2835d08326842fd6e988cc5db9dbee8646370997c4499b2e7275637904ffef8ac836e7766a294a900a10d5a36a36309e6ca6c91 SHA512 b294b4a0aad7a1d20eefd74c93494fe73248b1e75710219575f70a5c6203da3c8a1db0b8e28f6b5f1c18e415238005546f6c87218a87fd038ffa66c664fcae7b
+EBUILD lesspipe-2.06.ebuild 1318 BLAKE2B 28c664aad8277a4a49d1cc432f255738156ef98b6268d362c3d583bd3f34b868ce6a02487aee8c3b53aa2dfcbeaf22271e336ae1dccdb9639f17dc0367fe69cc SHA512 3b7fb6d9d7216648e5c8b02553bd87a729639f7293c9b5dab51dc9a69dd5741bef81ed54739d593effa1b7305779bee67e83b6c4604488e885e1fce31756035f
MISC metadata.xml 304 BLAKE2B bb5be96b5fd22ce82d800f6bd5ed3ceb04b955182eaadc1f34b6f4b633c21efd6148013fc29b5567f7ada4da5de6efd7e0e420fa63a2976a5cf6bcf719c34f2e SHA512 2c217e67c6c487f7f7f98588a50086daf434bc25ad229b68d37bc12f7ecc4f904b5bc4a3b7b6db4a1daa0267c7e13fde8538de1c16d11e95be6b8071ee675105
diff --git a/app-text/lesspipe/lesspipe-2.06.ebuild b/app-text/lesspipe/lesspipe-2.06.ebuild
new file mode 100644
index 000000000000..b16b5f900cda
--- /dev/null
+++ b/app-text/lesspipe/lesspipe-2.06.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="A preprocessor for less"
+HOMEPAGE="https://github.com/wofr06/lesspipe"
+SRC_URI="https://github.com/wofr06/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+# Please check again on bumps!
+# bug #734896
+RESTRICT="!test? ( test ) test"
+
+RDEPEND="dev-lang/perl"
+BDEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ test? ( app-editors/vim )
+"
+
+src_configure() {
+ # Not an autoconf script.
+ ./configure --fixed || die
+}
+
+src_compile() {
+ # Nothing to build (avoids the "all" target)
+ :
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install
+ einstalldocs
+
+ rm -r "${ED}"/etc/bashcompletion.d || die
+ newbashcomp less_completion less
+}
+
+pkg_preinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "This package installs 'lesspipe.sh' which is distinct from 'lesspipe'."
+ elog "The latter is the Gentoo-specific version. Make sure to update your"
+ elog "LESSOPEN environment variable if you wish to use this copy."
+ fi
+}