summaryrefslogtreecommitdiff
path: root/app-text/lcdf-typetools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /app-text/lcdf-typetools
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'app-text/lcdf-typetools')
-rw-r--r--app-text/lcdf-typetools/Manifest2
-rw-r--r--app-text/lcdf-typetools/lcdf-typetools-2.107.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/app-text/lcdf-typetools/Manifest b/app-text/lcdf-typetools/Manifest
index 6da500c587df..51e8468a761e 100644
--- a/app-text/lcdf-typetools/Manifest
+++ b/app-text/lcdf-typetools/Manifest
@@ -1,3 +1,5 @@
DIST lcdf-typetools-2.106.tar.gz 643503 BLAKE2B cb016da74dfbad92808292842de653badec4dd3b703fee5e177016856a795e1383ceeed68de668846cce167b7b9c74bd7e0b17ea3a60b2f9b9caa0b73444e02d SHA512 039215132585214e6518864161885f7a06f08f8b36b002a961b1d83182e388b31eb034eaa4466ba56a2af52e1cfb202e88f004be17c22df1343f94481e3114cf
+DIST lcdf-typetools-2.107.tar.gz 652445 BLAKE2B bbbc428673c8e036f8d3be8ec80dbcf8892f60976fee7f11d622af8442c4d3eda0e118d47b364f55fe0dc8b53062ece0926be1d67e6627500a787bce810c074c SHA512 be54d4346d567c640b260dc513854085901af96b82701fccb8f0feae4b373ac69962c568a648515eb9ebfcabc828359ab2d742947ccdf9422643b0d889961ff3
EBUILD lcdf-typetools-2.106.ebuild 890 BLAKE2B 9094d210f3bd6576fbd2810906252a3353b40b52ededad56b6e8ba49e0c48790e6b9dd4749137c681349f6125b7e6b4b94407daed968b7eeaeec4e8998c3a3bb SHA512 7775bda480cbbcb9a19575a10fd5b5e9081ccb3aa0e4a9419782662caf4926e2c4ff3498671232c6fd476c2d5a1f4cbdacd33b8626358700e9316b951d2fbe23
+EBUILD lcdf-typetools-2.107.ebuild 899 BLAKE2B 4d6c782a7fa16fd91b831d2b20aa691d05cb220af20dc66969bbb2f25b93fe5f20ec96c53de0d9b98590d5f14ff4ee3ec128427af31d26cb18d523ff4962c258 SHA512 f98c7da549aefa9cf75b4dd9b6d7129fbafb954756995af8e2628558a120205071d2bbff8de92cdb3e274b8501c11ae73f4ba7fed5cce2bb0fb0b3d30869977e
MISC metadata.xml 794 BLAKE2B c611036ee3c2daf88b72b026f0d8bec0e05595db2f73df051fb37793eda6304e1a32137e7759028ef4eb75bc56426d6ee2649d5384bbcc41c2da56d32a647b8e SHA512 9ae4e29814e34012d731aacc0a8b4a38649c95a988049f3fc10c7f260cb6ebcc57caa0a93d21eb8e66e64207673842ab7ab2fb71792ed3d537b7eca891609cba
diff --git a/app-text/lcdf-typetools/lcdf-typetools-2.107.ebuild b/app-text/lcdf-typetools/lcdf-typetools-2.107.ebuild
new file mode 100644
index 000000000000..d538c2e96354
--- /dev/null
+++ b/app-text/lcdf-typetools/lcdf-typetools-2.107.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Font utilities for eg manipulating OTF"
+SRC_URI="http://www.lcdf.org/type/${P}.tar.gz"
+HOMEPAGE="http://www.lcdf.org/type/#typetools"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="+kpathsea"
+
+RDEPEND="kpathsea? ( virtual/tex-base dev-libs/kpathsea )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ use kpathsea && has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
+ econf $(use_with kpathsea)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc NEWS.md README.md ONEWS
+}