summaryrefslogtreecommitdiff
path: root/app-text/krop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /app-text/krop
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'app-text/krop')
-rw-r--r--app-text/krop/Manifest4
-rw-r--r--app-text/krop/krop-0.6.0.ebuild42
-rw-r--r--app-text/krop/krop-9999.ebuild3
3 files changed, 47 insertions, 2 deletions
diff --git a/app-text/krop/Manifest b/app-text/krop/Manifest
index 3fc68e043d49..a4d16eb8c75f 100644
--- a/app-text/krop/Manifest
+++ b/app-text/krop/Manifest
@@ -1,4 +1,6 @@
DIST krop-0.5.1.tar.gz 42719 BLAKE2B e0baa3c14d9ce63815615eae004a08af720868d584262901eccbc569852177e07d5df659ea560d7e9cbdc4325daef8c35acd9c200440a8dfd73c19b274d8de37 SHA512 2bfd2a5d762454ab45538707c6f333d2b0947b6b203d6e7bd2d9d0d574d79de8ee6b30d87b17d6afea604456b915f323b855c9c9af5c169c192b0a01634075ca
+DIST krop-0.6.0.tar.gz 48331 BLAKE2B ca6a00a410ed4e18a401fab3a21bc49c86f73165f68b192ab83c8fad74111ba9a9941f464a2646faa5a3317bbb45cdc89bed19c901999c0b11db353ac2997a65 SHA512 51a988e4fcb65d11cc26cf5b0c808e79097a66ef8ec4751a6c051289cd77b3328ebc8ecd9829adc466f87330beb8bc715d290cc20be415a7b8f179378b7bcb4f
EBUILD krop-0.5.1-r1.ebuild 890 BLAKE2B 2a22e3e81c0c6d8154275fb8265a7dd2aab8e5528fc3e1dcd2bdd77e37f314b86e5dfa93577434fa56ffd8467c35a05a37914cffc747061fc46a43ca7e5d27c1 SHA512 6cab7d003e17681c842c2755887ac648cd7d90bcb46f557d18d6dc4c605a22d7584ff2af93eac336e8a8d316aa55b5d286272a792a9edb617301766b38b367c1
-EBUILD krop-9999.ebuild 891 BLAKE2B 560fb4ab2aa90d452dfe4a2f86666e50ab35e50501e9146c016d8c251d831e90f7ec089859f5ad1bab32d6698fcf8b62797453b2c36402660ee26e1009b181ce SHA512 71c2fe9b14063cd71200575a03b1a358703f1f5f33b351c496521dcc3660321a33fbd07a930dc64ef0c7270c489c54bb3b043903a89a9fd9c51e15e25324133c
+EBUILD krop-0.6.0.ebuild 947 BLAKE2B b179310ce8c3df53b833081a4d7e0798d9c95ebef78e65f518467589ca86ddc73581ec91278df2a3ee0482b535436326ecca9015b1ba307c7ce230691955382c SHA512 9d01edf0eda212529af80075a0609aa4e936d6ced2392441907d5a975fd51af5d76ecf82c20abf56db6741b1afe5fad7385284188d6f3c5db305a0b900def386
+EBUILD krop-9999.ebuild 947 BLAKE2B b179310ce8c3df53b833081a4d7e0798d9c95ebef78e65f518467589ca86ddc73581ec91278df2a3ee0482b535436326ecca9015b1ba307c7ce230691955382c SHA512 9d01edf0eda212529af80075a0609aa4e936d6ced2392441907d5a975fd51af5d76ecf82c20abf56db6741b1afe5fad7385284188d6f3c5db305a0b900def386
MISC metadata.xml 333 BLAKE2B b62d23170b13a4d2375de72955c2708368a34435f022231b829b19b60c9f38a1546ec62887dae545691eb1df45998ab7810aa58df3b94729632991e49c4c098f SHA512 30ec13878bbe3b50c90f1849bbc5bf0f8dc05bf1b6a8f79695590f48c76618eef4666965b8130d1909db3c960a43d3149dba525017f342ce9635afc530b873f0
diff --git a/app-text/krop/krop-0.6.0.ebuild b/app-text/krop/krop-0.6.0.ebuild
new file mode 100644
index 000000000000..3f7134934cdd
--- /dev/null
+++ b/app-text/krop/krop-0.6.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit desktop distutils-r1 xdg-utils
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/arminstraub/krop.git"
+else
+ SRC_URI="https://github.com/arminstraub/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A tool to crop PDF files"
+HOMEPAGE="http://arminstraub.com/software/krop"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/python-poppler-qt5[${PYTHON_USEDEP}]
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets]"
+
+src_install() {
+ distutils-r1_src_install
+ domenu "${WORKDIR}/${P}/${PN}.desktop"
+}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
diff --git a/app-text/krop/krop-9999.ebuild b/app-text/krop/krop-9999.ebuild
index 5dbe780b3d81..3f7134934cdd 100644
--- a/app-text/krop/krop-9999.ebuild
+++ b/app-text/krop/krop-9999.ebuild
@@ -3,6 +3,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit desktop distutils-r1 xdg-utils
@@ -10,7 +11,7 @@ if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/arminstraub/krop.git"
else
- SRC_URI="http://arminstraub.com/downloads/${PN}/${P}.tar.gz"
+ SRC_URI="https://github.com/arminstraub/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi