summaryrefslogtreecommitdiff
path: root/app-text/krop/krop-0.4.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/krop/krop-0.4.11.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/krop/krop-0.4.11.ebuild')
-rw-r--r--app-text/krop/krop-0.4.11.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-text/krop/krop-0.4.11.ebuild b/app-text/krop/krop-0.4.11.ebuild
new file mode 100644
index 000000000000..a4a95ac16ae7
--- /dev/null
+++ b/app-text/krop/krop-0.4.11.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="A tool to crop PDF files"
+HOMEPAGE="http://arminstraub.com/software/krop"
+SRC_URI="http://arminstraub.com/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/python-poppler-qt4[${PYTHON_USEDEP}]
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ dev-python/PyQt4[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+ domenu "${WORKDIR}/${P}/${PN}.desktop"
+}