summaryrefslogtreecommitdiff
path: root/app-text/kbibtex/kbibtex-0.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/kbibtex/kbibtex-0.6.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/kbibtex/kbibtex-0.6.2.ebuild')
-rw-r--r--app-text/kbibtex/kbibtex-0.6.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-text/kbibtex/kbibtex-0.6.2.ebuild b/app-text/kbibtex/kbibtex-0.6.2.ebuild
new file mode 100644
index 000000000000..1ed3726917b9
--- /dev/null
+++ b/app-text/kbibtex/kbibtex-0.6.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde4-base
+
+DESCRIPTION="BibTeX editor by KDE to edit bibliographies used with LaTeX"
+HOMEPAGE="https://userbase.kde.org/KBibTeX"
+SRC_URI="mirror://kde/stable/KBibTeX/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+DEPEND="
+ app-text/poppler[qt4]
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/qoauth:0
+ virtual/tex-base
+ x11-libs/libqxt
+"
+RDEPEND="${DEPEND}
+ dev-tex/bibtex2html
+"
+
+PATCHES=( "${FILESDIR}/${P}-webkit.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_QTWEBKIT=OFF
+ )
+
+ kde4-base_src_configure
+}