summaryrefslogtreecommitdiff
path: root/app-text/itex2mml/itex2mml-1.5.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/itex2mml/itex2mml-1.5.6.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/itex2mml/itex2mml-1.5.6.ebuild')
-rw-r--r--app-text/itex2mml/itex2mml-1.5.6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-text/itex2mml/itex2mml-1.5.6.ebuild b/app-text/itex2mml/itex2mml-1.5.6.ebuild
new file mode 100644
index 000000000000..16120ff44755
--- /dev/null
+++ b/app-text/itex2mml/itex2mml-1.5.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A LaTeX into XHTML/MathML converter"
+HOMEPAGE="https://golem.ph.utexas.edu/~distler/blog/itex2MML.html"
+SRC_URI="https://golem.ph.utexas.edu/~distler/blog/files/itexToMML-${PV}.tar.gz"
+LICENSE="|| ( GPL-2+ MPL-1.1 LGPL-2+ )"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/itexToMML/itex-src"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin itex2MML
+ dodoc ../README
+}