summaryrefslogtreecommitdiff
path: root/app-text/itex2mml/itex2mml-1.5.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/itex2mml/itex2mml-1.5.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/itex2mml/itex2mml-1.5.6.ebuild')
-rw-r--r--app-text/itex2mml/itex2mml-1.5.6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-text/itex2mml/itex2mml-1.5.6.ebuild b/app-text/itex2mml/itex2mml-1.5.6.ebuild
new file mode 100644
index 000000000000..d3d28f105538
--- /dev/null
+++ b/app-text/itex2mml/itex2mml-1.5.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A LaTeX into XHTML/MathML converter"
+HOMEPAGE="http://golem.ph.utexas.edu/~distler/blog/itex2MML.html"
+SRC_URI="http://golem.ph.utexas.edu/~distler/blog/files/itexToMML-${PV}.tar.gz"
+LICENSE="|| ( GPL-2+ MPL-1.1 LGPL-2+ )"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/itexToMML/itex-src"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin itex2MML
+ dodoc ../README
+}