summaryrefslogtreecommitdiff
path: root/app-text/iso-codes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-28 18:57:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-28 18:57:25 +0000
commit7b97d94d4769a556456398d66819200655c4d76c (patch)
tree2aab1b584f3ed787c1e858dbed720266bbb31bc5 /app-text/iso-codes
parentddcaaaec485fcf5238dfbabb6df62a11e95a1f26 (diff)
gentoo auto-resync : 28:01:2024 - 18:57:25
Diffstat (limited to 'app-text/iso-codes')
-rw-r--r--app-text/iso-codes/Manifest2
-rw-r--r--app-text/iso-codes/iso-codes-4.16.0.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/app-text/iso-codes/Manifest b/app-text/iso-codes/Manifest
index 5f7270cbfe2e..721fcb7cd1cf 100644
--- a/app-text/iso-codes/Manifest
+++ b/app-text/iso-codes/Manifest
@@ -1,3 +1,5 @@
DIST iso-codes-v4.15.0.tar.gz 15046318 BLAKE2B fc4a9dd6a80fbd7658e0ba30f483a57f7d487f5eb7cc73ac2504d24397f1a8519acf8bf2431b18f969cbe4dd8e386cedd82c9284d405c57c6682af7639b4aacb SHA512 1700c5c24a5a8c278df67539d7d99cae832a72e2fc604394b15af17cad78e36a9280e0a91ecaeade9e14b9f6431967ef2d2e662e73d200773e63455b0e1c5187
+DIST iso-codes-v4.16.0.tar.gz 15163129 BLAKE2B 8fcdb3c12c502c1e14169765db9c9dd7778fc5d4bb0da37aa6b27efeebd5ce9f3e825e5b1a7ae8d659babf2d6b9124af08b40ed8a2a1235e88df50be9c204ca5 SHA512 04d93eb37ff309c850a1af6d4cf6bb92a16e25ee35ee12e16325f6e7b476ba40bbf5d11e2f4c425111220480911b1dbc9e244189ea7487f1f0ea4dbce2307c96
EBUILD iso-codes-4.15.0.ebuild 2643 BLAKE2B 151045bc7c15754b8037456a8ea347f22ea88d84323e98d78ab28b44b2d4c256b39ae22e4eef0f144b78dd3c8986c88aa5baa2bd14b9892383b78974b62a181b SHA512 2c016f00030dd6893b81851fc6ce92b409e3b5bf4a40f3e350d6df41d2d25c00e0af586569a9f9dbf7099c4e4e100e244190202af80c5ff56c838294dcbd383c
+EBUILD iso-codes-4.16.0.ebuild 2645 BLAKE2B fbaa42614bee3ef094952fef6ad49a10d84f2c07c4f03ba8b588cad5f9d99b918bc952b19205d19e4a5aeda146f647dba7d88911f6fad74722d4cbca96774447 SHA512 7d864b091baf8a6e328881ee2c9bfe27b84ba8c449b1c834a196f84aebe522386ef981c78904e262785cdb6b416139dfe3e6a9f298555e65c16e4c4d7300409f
MISC metadata.xml 505 BLAKE2B d499c1a01fb2183ec86fcc3ca7af98dc8a2da444babb8a8234a1864093a67d0c247f68330bfd5625e01182bb181a97d35b42c74a8706cf61b2e2555b5275054c SHA512 96419d6d35801117584fd217d269bbce81e50523cadef397417f5218648de544bbb2f11eed4be1d55f5a3e456f15724ef3b2f0b0f26764471089be5d2bed7d7d
diff --git a/app-text/iso-codes/iso-codes-4.16.0.ebuild b/app-text/iso-codes/iso-codes-4.16.0.ebuild
new file mode 100644
index 000000000000..91e614fefbbc
--- /dev/null
+++ b/app-text/iso-codes/iso-codes-4.16.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+PLOCALES="ab ace ach af ak am an ar as ast ay az ba bar be bg bi bn bn_BD bn_IN br bs byn ca ce ch chr ckb crh cs csb cv cy da de dv dz ee el en eo es et eu fa ff fi fil fo fr frp fur fy ga gez gl gn gu gv ha haw he hi hr ht hu hy ia id io is it iu ja jam ka kab ki kk kl km kmr kn ko kok kv kw ky lo lt lv mai mhr mi mk ml mn mr ms mt my na nah nb_NO ne nl nn nso nv oc or pa pa_PK pap pi pl ps pt pt_BR ro ro_MD ru rw sc sd si sk sl so son sq sr sr@latin sv sw ta te tg th ti tig tk tl tr tt tt@iqtelif tzm ug uk ur uz ve vi wa wal wo xh yo zh_CN zh_HK zh_Hans zh_Hant zh_TW zu"
+
+inherit python-any-r1
+
+DESCRIPTION="ISO language, territory, currency, script codes and their translations"
+HOMEPAGE="https://salsa.debian.org/iso-codes-team/iso-codes"
+SRC_URI="https://salsa.debian.org/${PN}-team/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+BDEPEND="${PYTHON_DEPS}
+ sys-devel/gettext
+"
+S="${WORKDIR}/${PN}-v${PV}"
+
+# This ebuild does not install any binaries.
+RESTRICT="binchecks strip"
+
+DOCS=( CHANGELOG.md README.md )
+
+# plocale_find_changes doesn't support multiple directories,
+# so need to do the update scan ourselves.
+check_existing_locales() {
+ local std loc all_locales=()
+
+ ebegin "Looking for new locales"
+ for std in "${all_stds[@]}"; do
+ pushd "${std}" >/dev/null || die
+ for loc in *.po; do
+ all_locales+=( "${loc%.po}" )
+ done
+ popd >/dev/null
+ done
+
+ all_locales=$(echo $(printf '%s\n' "${all_locales[@]}" | LC_COLLATE=C sort -u))
+ if [[ ${PLOCALES} != "${all_locales}" ]]; then
+ eend 1
+ eerror "There are changes in locales! This ebuild should be updated to:"
+ eerror "PLOCALES=\"${all_locales}\""
+ die "Update PLOCALES in the ebuild"
+ else
+ eend 0
+ fi
+}
+
+src_prepare() {
+ default
+
+ local std loc mylinguas
+ local all_stds=( iso_15924 iso_3166-{1,2,3} iso_4217 iso_639-{2,3,5} )
+
+ check_existing_locales
+
+ # Modify the Makefiles so they only install requested locales.
+ for std in "${all_stds[@]}"; do
+ einfo "Preparing ${std} ..."
+ pushd "${std}" >/dev/null || die
+ mylinguas=()
+ for loc in *.po; do
+ if has ${loc%.po} ${LINGUAS-${loc%.po}}; then
+ mylinguas+=( "${loc}" )
+ fi
+ done
+
+ sed \
+ -e "/^pofiles =/s:=.*:= ${mylinguas[*]}:" \
+ -e "/^mofiles =/s:=.*:= ${mylinguas[*]/%.po/.mo}:" \
+ -i Makefile.am Makefile.in || die "sed in ${std} folder failed"
+ popd >/dev/null
+ done
+}