summaryrefslogtreecommitdiff
path: root/app-text/iso-codes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-28 16:04:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-28 16:04:24 +0000
commit158e7d0067767d034ef3a86a07afbf5bb9bf579f (patch)
treee845f4403370242aa438d03c25ff5813f01af6a4 /app-text/iso-codes
parent24a48769f03b243065aec42c384c39a2d2306964 (diff)
gentoo auto-resync : 28:02:2023 - 16:04:24
Diffstat (limited to 'app-text/iso-codes')
-rw-r--r--app-text/iso-codes/Manifest2
-rw-r--r--app-text/iso-codes/iso-codes-4.13.0.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/app-text/iso-codes/Manifest b/app-text/iso-codes/Manifest
index ab785a6b719e..525ea65d298a 100644
--- a/app-text/iso-codes/Manifest
+++ b/app-text/iso-codes/Manifest
@@ -1,3 +1,5 @@
DIST iso-codes-v4.12.0.tar.gz 14977180 BLAKE2B 23590e9a4f246a0879e68c521ae7f72f4dd8d41ef85e7b6efaa4e4a29b7bf2e45d5e200ae14523e4ef8d3d4c8f45e783d4231a2a1c679be1898aa04528da30d3 SHA512 d0cdac626728e4de7c5bb2f8edd968a29380d49ba2b43ebe3820756591e46d4301859da7961ec9fc9e6832e18a9a0d5562ec02dd3d8a52bec7f7cbfc3190869e
+DIST iso-codes-v4.13.0.tar.gz 14990054 BLAKE2B e9e9a166675c09ecfe62da92608e91d4d6aeb53306e6162ea432bba418d074ef54cf510071aae6407bdc1fe59c295e52e2c7862e0d5b8962f467834c117f4912 SHA512 fd180b8462eb1ee2fd49bc144fd8b1b866067512a5deec3f580689641c596f623a11f0384e8c05cb48de520e1ce7c0270a649ef37542ba51f93e244b45bc5bba
EBUILD iso-codes-4.12.0.ebuild 2650 BLAKE2B 488a6d6160722ee9b5e597bbf314ee420874b3fca46e7745f93383268da95c4680bcdb2024ce18e1f7380f103a5435f7431c75619c9d018180fdb97189a05bbe SHA512 ba0a30ce7ae5cbcb12b11ca0a1671c1f065c4d871db44c420716a20167f2cdb3fd4933b9405b9839177a456d28a56118bb29e16023b28b8e7bd4ca7ae74492a6
+EBUILD iso-codes-4.13.0.ebuild 2657 BLAKE2B 4e06e84be6ae2dcce8d5210bdbec62703fc218b5e59d4ff6abf6cdf58be9c2b724e09c5a21ee37dcd3a6c9c24c8c0fc13ec3983883a61193bc3f9e5eb81ee96a SHA512 cc47b6c8dcc2fd86d204d8fbd1b6afac492a8729d0de4e27337fb7036e57d01c07d7c5683ad1618779a22880d7af41532f65903547b7b00ee2c51df903ca95f3
MISC metadata.xml 481 BLAKE2B e19ee7de8b2de3aa09f97bb7eb4247ba2979614d768c0dd92a8cc131269e46a560baa1c0ea8fcceb49073efb1b890cd54d939c16ac7412413983a19083f05337 SHA512 f1e20f870fabd59d97ca612c3db3443a6a1544de3b03f12fe0c9c44a1740b06bf38c394b489738e60b22fa0797379d24c0ec8371efa067873910ba39fe30f194
diff --git a/app-text/iso-codes/iso-codes-4.13.0.ebuild b/app-text/iso-codes/iso-codes-4.13.0.ebuild
new file mode 100644
index 000000000000..2cb3270120b4
--- /dev/null
+++ b/app-text/iso-codes/iso-codes-4.13.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+PLOCALES="ab ace ach af ak am an ar as ast ay az ba bar be bg bi bn bn_BD bn_IN br bs byn ca ce ch chr ckb crh cs csb cv cy da de dv dz ee el en eo es et eu fa ff fi fil fo fr frp fur fy ga gez gl gn gu gv ha haw he hi hr ht hu hy ia id io is it iu ja jam ka kab ki kk kl km kmr kn ko kok kv kw ky lo lt lv mai mhr mi mk ml mn mo mr ms mt my na nah nb nb_NO ne nl nn nso nv oc or pa pa_PK pap pi pl ps pt pt_BR ro ru rw sc sd si sk sl so son sq sr sr@latin sv sw ta te tg th ti tig tk tl tr tt tt@iqtelif tzm ug uk ur uz ve vi wa wal wo xh yo zh_CN zh_HK zh_Hans zh_Hant zh_TW zu"
+
+inherit python-any-r1
+
+DESCRIPTION="ISO language, territory, currency, script codes and their translations"
+HOMEPAGE="https://salsa.debian.org/iso-codes-team/iso-codes"
+SRC_URI="https://salsa.debian.org/${PN}-team/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+
+BDEPEND="${PYTHON_DEPS}
+ sys-devel/gettext
+"
+S="${WORKDIR}/${PN}-v${PV}"
+
+# This ebuild does not install any binaries.
+RESTRICT="binchecks strip"
+
+DOCS=( CHANGELOG.md README.md )
+
+# plocale_find_changes doesn't support multiple directories,
+# so need to do the update scan ourselves.
+check_existing_locales() {
+ local std loc all_locales=()
+
+ ebegin "Looking for new locales"
+ for std in "${all_stds[@]}"; do
+ pushd "${std}" >/dev/null || die
+ for loc in *.po; do
+ all_locales+=( "${loc%.po}" )
+ done
+ popd >/dev/null
+ done
+
+ all_locales=$(echo $(printf '%s\n' "${all_locales[@]}" | LC_COLLATE=C sort -u))
+ if [[ ${PLOCALES} != "${all_locales}" ]]; then
+ eend 1
+ eerror "There are changes in locales! This ebuild should be updated to:"
+ eerror "PLOCALES=\"${all_locales}\""
+ die "Update PLOCALES in the ebuild"
+ else
+ eend 0
+ fi
+}
+
+src_prepare() {
+ default
+
+ local std loc mylinguas
+ local all_stds=( iso_15924 iso_3166-{1,2,3} iso_4217 iso_639-{2,3,5} )
+
+ check_existing_locales
+
+ # Modify the Makefiles so they only install requested locales.
+ for std in "${all_stds[@]}"; do
+ einfo "Preparing ${std} ..."
+ pushd "${std}" >/dev/null || die
+ mylinguas=()
+ for loc in *.po; do
+ if has ${loc%.po} ${LINGUAS-${loc%.po}}; then
+ mylinguas+=( "${loc}" )
+ fi
+ done
+
+ sed \
+ -e "/^pofiles =/s:=.*:= ${mylinguas[*]}:" \
+ -e "/^mofiles =/s:=.*:= ${mylinguas[*]/%.po/.mo}:" \
+ -i Makefile.am Makefile.in || die "sed in ${std} folder failed"
+ popd >/dev/null
+ done
+}