summaryrefslogtreecommitdiff
path: root/app-text/hunspell/hunspell-1.7.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-03 14:26:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-03 14:26:22 +0000
commit5aede38e7304fc5c3bd8a2034b25758b15a19fa0 (patch)
tree95f6b79a072854ddd86f7932f876acb7fbaf7752 /app-text/hunspell/hunspell-1.7.0-r2.ebuild
parent2f28d79786e67cf29825843d6d04d4591a27f9cf (diff)
gentoo auto-resync : 03:01:2023 - 14:26:21
Diffstat (limited to 'app-text/hunspell/hunspell-1.7.0-r2.ebuild')
-rw-r--r--app-text/hunspell/hunspell-1.7.0-r2.ebuild80
1 files changed, 0 insertions, 80 deletions
diff --git a/app-text/hunspell/hunspell-1.7.0-r2.ebuild b/app-text/hunspell/hunspell-1.7.0-r2.ebuild
deleted file mode 100644
index 18d75871d37b..000000000000
--- a/app-text/hunspell/hunspell-1.7.0-r2.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LANGS="af bg ca cs cy da de de-1901 el en eo es et fo fr ga gl he hr hu ia id is
-it kk km ku lt lv mi mk ms nb nl nn pl pt pt-BR ro ru sk sl sq sv sw tn uk zu"
-inherit autotools flag-o-matic
-
-DESCRIPTION="Spell checker, morphological analyzer library and command-line tool"
-HOMEPAGE="https://hunspell.github.io/"
-SRC_URI="https://github.com/hunspell/hunspell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MPL-1.1 GPL-2 LGPL-2.1"
-SLOT="0/$(ver_cut 1-2)"
-IUSE="ncurses nls readline static-libs"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-
-RDEPEND="
- ncurses? ( sys-libs/ncurses:0= )
- readline? ( sys-libs/readline:= )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="sys-devel/gettext"
-
-PDEPEND=""
-for lang in ${LANGS}; do
- IUSE+=" l10n_${lang}"
- case ${lang} in
- de-1901) dict="de_1901" ;;
- pt-BR) dict="pt-br" ;;
- *) dict="${lang}" ;;
- esac
- PDEPEND+=" l10n_${lang}? ( app-dicts/myspell-${dict} )"
-done
-unset dict lang LANGS
-
-DOCS=( AUTHORS ChangeLog NEWS THANKS license.{hunspell,myspell} README.md )
-
-PATCHES=(
- # Upstream package creates some executables which names are too generic
- # to be placed in /usr/bin - this patch prefixes them with 'hunspell-'.
- # It modifies a Makefile.am file, hence eautoreconf.
- "${FILESDIR}/${PN}-1.7.0-renameexes.patch"
-
- "${FILESDIR}/${PN}-1.7.0-tinfo.patch" #692614
- "${FILESDIR}/${PN}-1.7.0-CVE-2019-16707.patch"
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- # missing somehow, and I am too lazy to fix it properly
- [[ ${CHOST} == *-darwin* ]] && append-libs -liconv
-
- # I wanted to put the include files in /usr/include/hunspell.
- # You can do that, libreoffice can find them anywhere, just
- # ping me when you do so ; -- scarabeus
- local myeconfargs=(
- $(use_enable nls)
- $(use_with ncurses ui)
- $(use_with readline readline)
- $(use_enable static-libs static)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- einstalldocs
- find "${ED}" -type f -name '*.la' -delete || die
-
- #342449
- pushd "${ED}"/usr/$(get_libdir)/ >/dev/null
- ln -s lib${PN}{-$(ver_cut 1).$(ver_cut 2).so.0.0.1,.so}
- popd >/dev/null
-}