summaryrefslogtreecommitdiff
path: root/app-text/htp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/htp
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/htp')
-rw-r--r--app-text/htp/Manifest4
-rw-r--r--app-text/htp/files/strip.patch15
-rw-r--r--app-text/htp/htp-1.16-r1.ebuild49
-rw-r--r--app-text/htp/metadata.xml11
4 files changed, 79 insertions, 0 deletions
diff --git a/app-text/htp/Manifest b/app-text/htp/Manifest
new file mode 100644
index 000000000000..26c2ba9332e4
--- /dev/null
+++ b/app-text/htp/Manifest
@@ -0,0 +1,4 @@
+AUX strip.patch 261 BLAKE2B 760a04284f2b79e942fbee21d7b075d41c047f8f7f5eca563f6754e4a9fec1c372986dbcc965f2a1009ac26f8347868f7c0cb4bb767ac98c3be8b2895c49677f SHA512 2f2a9afb828e9de08fa97ca2798a0d2dc6f65cbf192cbc749c3790ed542f75c49c5fbb4644fb8017f93dc24a42c584914d5659841a211c1fe74a3aa43be633e4
+DIST htp-1.16.tar.gz 141133 BLAKE2B 58f0ab7df1400d561ec1994a98ce4fa3acaa3299b51d9382f9baaecbd95a623795d72204617c153fd4e165910fdabd0328e737cccb242be2075edd2573af55c1 SHA512 f33a9497fc3a1d0b95d8e3ee2747583d58626b565644e7c8cc054570458907aac9db42c6fa816b176b0e10db98ec7d1cedb521406035a8e7173e1abd991533a0
+EBUILD htp-1.16-r1.ebuild 1254 BLAKE2B a2c8cce1c8d85d069dfc094dea5e60be6ad9adce7e31c5d692fcfec411a3bc1b0f79967a14f7b5f0682abcfa3998bf4cbde25f8572292f998a1d42c499eb8703 SHA512 0217b514defbe8cbf8bfee84c53287a3bd93b1841b4ae3c2bbd8927833174321c77e4b67c26d0587cfc0d855e76497af42cf04b179eb39a0cd2a218042a3b897
+MISC metadata.xml 323 BLAKE2B 815632fb1a839f62a7e2201270b77e1cb16955e5bcc978bebd09d0501eb2df6f56bf20a8ed6a7c2ed6d7a5fcb5d0900a06c38f22dc649c731ada0d36478f3aa1 SHA512 f5c0a7720bd23aa0c604e0ffa07e2925afe69f9af09c9364818e16197fdf55c1decac5839234cdb08e483be1bfb4d0a88279e57c2b48c0002d3de27e90616f26
diff --git a/app-text/htp/files/strip.patch b/app-text/htp/files/strip.patch
new file mode 100644
index 000000000000..9c92e757bc9e
--- /dev/null
+++ b/app-text/htp/files/strip.patch
@@ -0,0 +1,15 @@
+don't strip
+
+http://bugs.gentoo.org/240110
+
+--- src/Makefile
++++ src/Makefile
+@@ -33,7 +33,7 @@
+
+ install-bin: $(MAINEXE)
+ mkdir -p $(bindir)
+- $(INSTALL) -s $(MAINEXE) $(bindir)
++ $(INSTALL) $(MAINEXE) $(bindir)
+
+ #
+ # explicit dependency: final executable
diff --git a/app-text/htp/htp-1.16-r1.ebuild b/app-text/htp/htp-1.16-r1.ebuild
new file mode 100644
index 000000000000..f3fd15c02c87
--- /dev/null
+++ b/app-text/htp/htp-1.16-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An HTML preprocessor"
+HOMEPAGE="http://htp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="Clarified-Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~ppc ~sparc ~x86"
+IUSE=""
+
+# HTP does not use autoconf, have to set options defined in Makefile.config
+
+src_prepare() {
+ epatch "${FILESDIR}"/strip.patch #240110
+ # let src_test take care of testing
+ sed -i -e '/SUBDIRS /s:tests::' Makefile || die
+ # don't install doc files with +x perms
+ sed -i -e '$aINSTALL += -m644' homepage/ref/{*/,}Makefile || die
+ # make src_test abort on failure
+ sed -i -e '/DIFF.*FAILED/s/echo/exit 1; :/' tests/Makefile || die
+ # the png file in this test isn't fetchable
+ sed -i -e 's: width="630" height="331"::' tests/png.html.exp || die
+}
+
+src_compile() {
+ emake \
+ CCOPT="-c ${CFLAGS} ${CPPFLAGS} -DHAVE_SNPRINTF -DHAVE_VASPRINTF -DHAVE_ASPRINTF" \
+ CC="$(tc-getCC)" \
+ LINK='$(CC) $(LDFLAGS)' \
+ || die
+}
+
+src_test() {
+ emake -C tests || die
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ prefix='$(DESTDIR)/usr' \
+ pkgdocdir='$(DESTDIR)/usr/share/doc/${PF}/html' \
+ install || die
+}
diff --git a/app-text/htp/metadata.xml b/app-text/htp/metadata.xml
new file mode 100644
index 000000000000..ae333307c43c
--- /dev/null
+++ b/app-text/htp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>web-apps@gentoo.org</email>
+ <name>Gentoo Webapps</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">htp</remote-id>
+ </upstream>
+</pkgmetadata>