summaryrefslogtreecommitdiff
path: root/app-text/htmltidy/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/htmltidy/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/htmltidy/files')
-rw-r--r--app-text/htmltidy/files/11CVE-2015-5522.patch34
-rw-r--r--app-text/htmltidy/files/htmltidy-20090325-tidyrc.patch31
-rw-r--r--app-text/htmltidy/files/htmltidy-5.10.26-strip-O2-flag.patch12
3 files changed, 77 insertions, 0 deletions
diff --git a/app-text/htmltidy/files/11CVE-2015-5522.patch b/app-text/htmltidy/files/11CVE-2015-5522.patch
new file mode 100644
index 000000000000..b4d6158ea04a
--- /dev/null
+++ b/app-text/htmltidy/files/11CVE-2015-5522.patch
@@ -0,0 +1,34 @@
+From c18f27a58792f7fbd0b30a0ff50d6b40a82f940d Mon Sep 17 00:00:00 2001
+From: Geoff McLane <ubuntu@geoffair.info>
+Date: Wed, 3 Jun 2015 20:26:03 +0200
+Subject: [PATCH] Issue #217 - avoid len going negative, ever...
+
+---
+ src/lexer.c | 8 +++++---
+ 1 file changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/src/lexer.c b/src/lexer.c
+index 376a3d8..664f806 100644
+--- a/src/lexer.c
++++ b/src/lexer.c
+@@ -3739,16 +3740,17 @@ static tmbstr ParseValue( TidyDocImpl* doc, ctmbstr name,
+ /* and prompts attributes unless --literal-attributes is set to yes */
+ /* #994841 - Whitespace is removed from value attributes */
+
+- if (munge &&
++ /* Issue #217 - Also only if/while (len > 0) - MUST NEVER GO NEGATIVE! */
++ if ((len > 0) && munge &&
+ TY_(tmbstrcasecmp)(name, "alt") &&
+ TY_(tmbstrcasecmp)(name, "title") &&
+ TY_(tmbstrcasecmp)(name, "value") &&
+ TY_(tmbstrcasecmp)(name, "prompt"))
+ {
+- while (TY_(IsWhite)(lexer->lexbuf[start+len-1]))
++ while (TY_(IsWhite)(lexer->lexbuf[start+len-1]) && (len > 0))
+ --len;
+
+- while (TY_(IsWhite)(lexer->lexbuf[start]) && start < len)
++ while (TY_(IsWhite)(lexer->lexbuf[start]) && (start < len) && (len > 0))
+ {
+ ++start;
+ --len;
diff --git a/app-text/htmltidy/files/htmltidy-20090325-tidyrc.patch b/app-text/htmltidy/files/htmltidy-20090325-tidyrc.patch
new file mode 100644
index 000000000000..942a61e1464c
--- /dev/null
+++ b/app-text/htmltidy/files/htmltidy-20090325-tidyrc.patch
@@ -0,0 +1,31 @@
+Index: tidy-20090325/include/platform.h
+===================================================================
+--- tidy-20090325.orig/include/platform.h
++++ tidy-20090325/include/platform.h
+@@ -24,7 +24,7 @@ extern "C" {
+ */
+
+ /* #define TIDY_CONFIG_FILE "/etc/tidy_config.txt" */ /* original */
+-/* #define TIDY_CONFIG_FILE "/etc/tidyrc" */
++#define TIDY_CONFIG_FILE "/etc/tidyrc"
+ /* #define TIDY_CONFIG_FILE "/etc/tidy.conf" */
+
+ /*
+@@ -33,7 +33,7 @@ extern "C" {
+ It enables tidy to find config files named ~/.tidyrc if
+ the HTML_TIDY environment variable is not set.
+ */
+-/* #define TIDY_USER_CONFIG_FILE "~/.tidyrc" */
++#define TIDY_USER_CONFIG_FILE "~/.tidyrc"
+
+ /*
+ Uncomment the following #define if your
+@@ -48,7 +48,7 @@ extern "C" {
+ Contributed by Todd Lewis.
+ */
+
+-/* #define SUPPORT_GETPWNAM */
++#define SUPPORT_GETPWNAM
+
+
+ /* Enable/disable support for Big5 and Shift_JIS character encodings */
diff --git a/app-text/htmltidy/files/htmltidy-5.10.26-strip-O2-flag.patch b/app-text/htmltidy/files/htmltidy-5.10.26-strip-O2-flag.patch
new file mode 100644
index 000000000000..4c805cf2226f
--- /dev/null
+++ b/app-text/htmltidy/files/htmltidy-5.10.26-strip-O2-flag.patch
@@ -0,0 +1,12 @@
+diff -urN tidy.old/configure.in tidy-26/configure.in
+--- tidy.old/configure.in 2006-02-13 17:17:49.000000000 +0100
++++ tidy-26/configure.in 2006-02-13 17:17:20.000000000 +0100
+@@ -72,7 +72,7 @@
+ if test $debug_build = yes; then
+ CFLAGS="$save_cflags -g"
+ else
+- CFLAGS="-O2 $save_cflags"
++ CFLAGS="$save_cflags"
+ fi
+ #
+ # =============================================