summaryrefslogtreecommitdiff
path: root/app-text/htmlmin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/htmlmin
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/htmlmin')
-rw-r--r--app-text/htmlmin/Manifest5
-rw-r--r--app-text/htmlmin/htmlmin-0.1.11_pre20170909.ebuild28
-rw-r--r--app-text/htmlmin/htmlmin-0.1.12.ebuild25
-rw-r--r--app-text/htmlmin/metadata.xml15
4 files changed, 73 insertions, 0 deletions
diff --git a/app-text/htmlmin/Manifest b/app-text/htmlmin/Manifest
new file mode 100644
index 000000000000..3d4987d3b593
--- /dev/null
+++ b/app-text/htmlmin/Manifest
@@ -0,0 +1,5 @@
+DIST htmlmin-0.1.11_pre20170909.tar.gz 123229 BLAKE2B 7cc22370afa045ac13bf05082d396534e08a454f13f6bf321bc45c4743c33813bc32c31b655c21d731f091f11d13aeef405bc82c8e2b0ed0d0a12a25e4e7f3ad SHA512 85b29bca8f40680574fa21e2720a6b573ba69b94c239cdbcea80cdb1d0032bbf0d735f596f2a3beb3b3691b2366cdfd6051dd2499eaeb6b4b7618c7b59ebd7ec
+DIST htmlmin-0.1.12.tar.gz 19940 BLAKE2B 66e9596f687b70fa44362078075cb5f70553e65a7a1a6c55a4abac6adc5d0821b8936507cbb56f4e8ea96575a8801ec341416fead54b18ff9e10d199ed506529 SHA512 5669327dc64d8d28accdfe0d9a222e723fccdc12b52e7f0315fb9caf958a734a0cf0514ad476cbd0b7d0f2d83514a207867127f135f5e51cfda9b15dbfe24b78
+EBUILD htmlmin-0.1.11_pre20170909.ebuild 634 BLAKE2B 9a55a43ee6ffaa3e5a363df3f776164e9671ff0c43d121bf575ef43a5e8d6de35368cc187e8af782f14a993966f8f141dc93df7eaf89d72422d757a6f881e0ab SHA512 c39a88b40626f7e8e943d8ef05fc355d523d13b65577c6e535139e8fa958489a83490bbff47a9cef2595f1e3c871512e4083bc3b115864f2d6644662e7a2b608
+EBUILD htmlmin-0.1.12.ebuild 508 BLAKE2B 57fa9adb75cea920eb9ef209a31f8c329315f22c269c75f714a149d8e1c07b4fba41b6a6c8fd9e170058555c1e455b05ab5d718c8a7d027e46b2792efb4ee34c SHA512 97feee6c9be7a7d96cf9a0acf2b70b2580c6e240d9de77c5487e1df260fa4327c1a365bd1d182a50fffde330b82411673514d40c9da546476fb648af13037593
+MISC metadata.xml 424 BLAKE2B 1026b0d3b470845caf9f575527f76c10b691c855426e5fe48972943ca067e9c4211f3e5af025b85f3881c321614c174f6c2f751c2f3f0764aedf04abb2dfe125 SHA512 53ae65ab7e6dd530f398c228e7ad38242a367efdd398a5bd321704e42f33b997c4fc5bfb942a90722b164ff29b35c1f6e3d3e15414241995bd371c3090c250e0
diff --git a/app-text/htmlmin/htmlmin-0.1.11_pre20170909.ebuild b/app-text/htmlmin/htmlmin-0.1.11_pre20170909.ebuild
new file mode 100644
index 000000000000..162bd42974d4
--- /dev/null
+++ b/app-text/htmlmin/htmlmin-0.1.11_pre20170909.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+HTMLMIN_GIT_REVISION="7bcbb995778fc07e427872dc74af9646fd0c907d"
+
+DESCRIPTION="A configurable HTML Minifier with safety features"
+HOMEPAGE="https://github.com/mankyd/htmlmin"
+SRC_URI="https://github.com/mankyd/${PN}/archive/${HTMLMIN_GIT_REVISION}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed '/prune/d' -i MANIFEST.in
+ default
+}
diff --git a/app-text/htmlmin/htmlmin-0.1.12.ebuild b/app-text/htmlmin/htmlmin-0.1.12.ebuild
new file mode 100644
index 000000000000..cdddc86d92a3
--- /dev/null
+++ b/app-text/htmlmin/htmlmin-0.1.12.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A configurable HTML Minifier with safety features"
+HOMEPAGE="https://github.com/mankyd/htmlmin"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed '/prune/d' -i MANIFEST.in
+ default
+}
diff --git a/app-text/htmlmin/metadata.xml b/app-text/htmlmin/metadata.xml
new file mode 100644
index 000000000000..2b2dd5ca9914
--- /dev/null
+++ b/app-text/htmlmin/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>titanofold@gentoo.org</email>
+ <name>Aaron W. Swenson</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">htmlmin</remote-id>
+ </upstream>
+</pkgmetadata>