summaryrefslogtreecommitdiff
path: root/app-text/htmlmin/htmlmin-0.1.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /app-text/htmlmin/htmlmin-0.1.12.ebuild
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'app-text/htmlmin/htmlmin-0.1.12.ebuild')
-rw-r--r--app-text/htmlmin/htmlmin-0.1.12.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/app-text/htmlmin/htmlmin-0.1.12.ebuild b/app-text/htmlmin/htmlmin-0.1.12.ebuild
index fc8e480e3b33..080c078b2222 100644
--- a/app-text/htmlmin/htmlmin-0.1.12.ebuild
+++ b/app-text/htmlmin/htmlmin-0.1.12.ebuild
@@ -1,25 +1,29 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
+# upstream doesn't do tags much
+EGIT_COMMIT=220b1d16442eb4b6fafed338ee3b61f698a01e63
DESCRIPTION="A configurable HTML Minifier with safety features"
HOMEPAGE="https://github.com/mankyd/htmlmin"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="
+ https://github.com/mankyd/htmlmin/archive/${EGIT_COMMIT}.tar.gz
+ -> ${P}.gh.tar.gz"
+S=${WORKDIR}/${PN}-${EGIT_COMMIT}
LICENSE="BSD"
-
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+distutils_enable_tests setup.py
src_prepare() {
sed '/prune/d' -i MANIFEST.in || die
- default
+ distutils-r1_src_prepare
}