summaryrefslogtreecommitdiff
path: root/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild')
-rw-r--r--app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild31
1 files changed, 12 insertions, 19 deletions
diff --git a/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild b/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild
index 694412759ced..a2d1afc50502 100644
--- a/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild
+++ b/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild
@@ -1,37 +1,30 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="HTML Include System by Ulli Meybohm"
HOMEPAGE="http://www.meybohm.de/"
-SRC_URI="http://meybohm.de/files/${PN}.tar.gz"
+SRC_URI="mirror://gentoo/${PN}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc sparc x86 ~x86-linux ~ppc-macos ~x86-macos"
-IUSE=""
-S=${WORKDIR}/htmlinc
+S="${WORKDIR}/${PN}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-gcc3-gentoo.patch
+ "${FILESDIR}"/${P}-fix-build-system.patch
+)
-src_prepare() {
- epatch "${FILESDIR}"/htmlinc-gcc3-gentoo.patch
- sed -i Makefile \
- -e 's| -o | $(LDFLAGS)&|g' \
- || die "sed Makefile"
-}
-
-src_compile() {
- # This is C++ not C source
- emake \
- CC=$(tc-getCXX) \
- CFLAGS="${CXXFLAGS} -Wall" \
- LDFLAGS="${LDFLAGS}"
+src_configure() {
+ tc-export CXX
+ append-cxxflags -Wall
}
src_install() {
dobin htmlinc
- dodoc README
+ einstalldocs
}