summaryrefslogtreecommitdiff
path: root/app-text/html2text/html2text-1.3.2a-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /app-text/html2text/html2text-1.3.2a-r2.ebuild
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'app-text/html2text/html2text-1.3.2a-r2.ebuild')
-rw-r--r--app-text/html2text/html2text-1.3.2a-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-text/html2text/html2text-1.3.2a-r2.ebuild b/app-text/html2text/html2text-1.3.2a-r2.ebuild
new file mode 100644
index 000000000000..f96c4819e230
--- /dev/null
+++ b/app-text/html2text/html2text-1.3.2a-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="HTML to text converter"
+HOMEPAGE="http://www.mbayer.de/html2text/"
+SRC_URI="http://www.mbayer.de/html2text/downloads/${P}.tar.gz
+ http://www.mbayer.de/html2text/downloads/patch-utf8-${P}.diff
+ http://www.mbayer.de/html2text/downloads/patch-amd64-${P}.diff
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+PATCHES=(
+ "${FILESDIR}/${P}-compiler.patch"
+ "${FILESDIR}/${P}-urlistream-get.patch"
+ "${DISTDIR}/patch-utf8-${P}.diff"
+ "${DISTDIR}/patch-amd64-${P}.diff"
+)
+
+src_prepare() {
+ default
+ gunzip html2text.1.gz html2textrc.5.gz || die
+ tc-export CXX
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" DEBUG="${CXXFLAGS}"
+}
+
+src_install() {
+ dobin html2text
+ doman html2text.1 html2textrc.5
+ dodoc CHANGES CREDITS KNOWN_BUGS README TODO
+}