summaryrefslogtreecommitdiff
path: root/app-text/html-xml-utils/html-xml-utils-8.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-11 05:45:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-11 05:45:51 +0100
commit980af9d76d4b7d7541b41eeff427e5cbd5cf7ec3 (patch)
tree0b86d672e967b7f78ba20788fd85818efd54dc01 /app-text/html-xml-utils/html-xml-utils-8.6.ebuild
parentf356af92b88d56b78588e81310493d4f5a2f6d18 (diff)
gentoo auto-resync : 11:05:2023 - 05:45:51
Diffstat (limited to 'app-text/html-xml-utils/html-xml-utils-8.6.ebuild')
-rw-r--r--app-text/html-xml-utils/html-xml-utils-8.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-text/html-xml-utils/html-xml-utils-8.6.ebuild b/app-text/html-xml-utils/html-xml-utils-8.6.ebuild
new file mode 100644
index 000000000000..29a2f7e8e4d0
--- /dev/null
+++ b/app-text/html-xml-utils/html-xml-utils-8.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A number of simple utilities for manipulating HTML and XML files"
+HOMEPAGE="https://www.w3.org/Tools/HTML-XML-utils/"
+SRC_URI="https://www.w3.org/Tools/HTML-XML-utils/${P}.tar.gz"
+
+LICENSE="W3C"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-linux ~ppc-macos"
+
+RDEPEND="
+ net-dns/libidn2:=
+ net-misc/curl
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -e "/doc_DATA = COPYING/d" -i Makefile.in || die
+}
+
+src_test() {
+ # Lots of tests lack a shebang and use bashisms
+ # (seems to be better wrt bashisms as of 8.6, but still no shebang. recheck?)
+ emake check SHELL="${BROOT}"/bin/bash
+}