summaryrefslogtreecommitdiff
path: root/app-text/hnb/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/hnb/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/hnb/files')
-rw-r--r--app-text/hnb/files/hnb-1.9.18-flags.patch83
-rw-r--r--app-text/hnb/files/hnb-1.9.18-include.patch13
-rw-r--r--app-text/hnb/files/hnb-1.9.18-printf.patch11
3 files changed, 107 insertions, 0 deletions
diff --git a/app-text/hnb/files/hnb-1.9.18-flags.patch b/app-text/hnb/files/hnb-1.9.18-flags.patch
new file mode 100644
index 000000000000..4111b7078d70
--- /dev/null
+++ b/app-text/hnb/files/hnb-1.9.18-flags.patch
@@ -0,0 +1,83 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,19 +1,19 @@
+
+ src/hnb: src/*.c src/*.h src/*.inc src/hnbrc.inc
+- (cd src;make)
++ (cd src;$(MAKE))
+ install: src/hnb
+ install -D src/hnb /usr/local/bin/hnb
+ install -D -m444 doc/hnb.1 /usr/local/man/man1/hnb.1
+ clean:
+- (cd src;make clean)
+- (cd util;make clean)
++ (cd src;$(MAKE) clean)
++ (cd util;$(MAKE) clean)
+ rm -f *~
+
+ rcupdate: updaterc
+ updaterc: src/hnbrc.inc
+
+ src/hnbrc.inc: doc/hnbrc
+- (cd util;make)
++ (cd util;$(MAKE))
+ echo -n "\"">src/hnbrc.inc
+ cat doc/hnbrc | util/asc2c >> src/hnbrc.inc
+ echo "\"">>src/hnbrc.inc
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -1,5 +1,6 @@
+-LIBS=-lncurses libcli/libcli.a
+-CFLAGS=-I.. -Ilibcli -DHAVE_CONFIG_H -Wall -pedantic -g
++LIBS=$(shell ${PKG_CONFIG} --libs ncurses) libcli/libcli.a
++CFLAGS+=-Wall -pedantic
++CPPFLAGS+=-I.. -Ilibcli -DHAVE_CONFIG_H
+
+ CFILES=$(wildcard *.c)
+ OBJS=$(patsubst %.c,%.o,$(CFILES))
+@@ -8,22 +9,22 @@
+ $(CC) -c $(CFLAGS) $(CPPFLAGS) -o $@ $<
+
+ hnb: libcli/libcli.a Makefile $(OBJS) init_subsystems.c *.h *.inc
+- $(CC) -o hnb $(OBJS) $(LIBS) $(CFLAGS)
++ $(CC) -o hnb $(OBJS) $(LIBS) $(CFLAGS) $(LDFLAGS)
+ # strip hnb
+ libcli/libcli.a: libcli/*.c
+- (cd libcli;make libcli.a)
++ (cd libcli;$(MAKE) libcli.a)
+ libcli/libcli_p.a: libcli/*.c
+- (cd libcli;make libcli_p.a)
+-init_subsystems.c: *.c
++ (cd libcli;$(MAKE) libcli_p.a)
++init_subsystems.c: $(CFILES)
+ echo "/* this file is autogenerated, do not edit */">init_subsystems.c
+- cat *.c | grep "^\!init_" | sort | sed -e "s/^\!/void /g">>init_subsystems.c
++ cat $(CFILES) | grep "^\!init_" | sort | sed -e "s/^\!/void /g">>init_subsystems.c
+ echo "">>init_subsystems.c
+ echo "void init_subsystems(){">>init_subsystems.c
+- cat *.c | grep "^\!init_" | sort | sed -e "s/^\!/ /g">>init_subsystems.c
++ cat $(CFILES) | grep "^\!init_" | sort | sed -e "s/^\!/ /g">>init_subsystems.c
+ echo "}">>init_subsystems.c
+ clean:
+ rm -f xml_debug hnb $(OBJS) *~ cli_*.inc
+- (cd libcli;make clean)
++ (cd libcli;$(MAKE) clean)
+ hnb_p: *.c libcli/libcli_p.a init_subsystems.c
+ $(CC) -o hnb_p *.c -pg -lncurses_p libcli/libcli_p.a -I.. -Ilibcli -DHAVE_CONFIG_H
+
+--- a/src/libcli/Makefile
++++ b/src/libcli/Makefile
+@@ -7,11 +7,11 @@
+ clean:
+ rm -f *.o *.a *.so test-s* *~
+ libcli.a: $(OBJS)
+- ar rc libcli.a cli*.o
++ $(AR) rc libcli.a cli*.o
+ libcli_p.a:
+ $(CC) -pg -c cli.c
+ $(CC) -pg -c cli_history.c
+- ar rcs libcli_p.a cli*.o
++ $(AR) rcs libcli_p.a cli*.o
+ libcli.so: $(OBJS)
+ $(CC) -shared cli*.o -o libcli.so $(CFLAGS) $(LIBS)
+ test-static: test.o libcli.a
diff --git a/app-text/hnb/files/hnb-1.9.18-include.patch b/app-text/hnb/files/hnb-1.9.18-include.patch
new file mode 100644
index 000000000000..9ee57a351d51
--- /dev/null
+++ b/app-text/hnb/files/hnb-1.9.18-include.patch
@@ -0,0 +1,13 @@
+--- a/src/expanded.c
++++ b/src/expanded.c
+@@ -18,9 +18,9 @@
+ * Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ */
+
++#include <string.h>
+ #include "tree.h"
+ #include "cli.h"
+-#define NULL 0
+
+ #include "evilloop.h"
+ #include "ctype.h"
diff --git a/app-text/hnb/files/hnb-1.9.18-printf.patch b/app-text/hnb/files/hnb-1.9.18-printf.patch
new file mode 100644
index 000000000000..d8ac27efb643
--- /dev/null
+++ b/app-text/hnb/files/hnb-1.9.18-printf.patch
@@ -0,0 +1,11 @@
+--- a/src/libcli/cli.c
++++ b/src/libcli/cli.c
+@@ -57,7 +57,7 @@
+ wp=word;
+ *wp='\0';
+ } else {
+- printf(tbuf);printf("\n");
++ printf("%s\n", tbuf);
+ bp=tbuf;
+ *bp='\0';
+ strcpy(bp,word);