summaryrefslogtreecommitdiff
path: root/app-text/hd2u/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/hd2u/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/hd2u/files')
-rw-r--r--app-text/hd2u/files/hd2u-1.0.3-build.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-text/hd2u/files/hd2u-1.0.3-build.patch b/app-text/hd2u/files/hd2u-1.0.3-build.patch
new file mode 100644
index 000000000000..de788e8aa774
--- /dev/null
+++ b/app-text/hd2u/files/hd2u-1.0.3-build.patch
@@ -0,0 +1,25 @@
+diff --git a/Makefile.in b/Makefile.in
+index 2a67b3c..651323d 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -42,7 +42,7 @@ LIBS= @LIBS@
+ all: $(TARGET)
+
+ $(TARGET): $(TARGET).c config.h
+- $(CC) $(CFLAGS) -o $@ $(@:%=%.c) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(@:%=%.c) $(LIBS)
+
+
+ all-optimized: $(TARGET)-optimized
+@@ -98,9 +98,10 @@ cleanall: clean
+ mrproper: cleanall
+ distclean: cleanall
+
++BUILD_ROOT=$(DESTDIR)
+ install:
+ $(INSTALL) -d -m 755 $(BUILD_ROOT)$(BIN_DIR)
+- $(INSTALL) -m 755 -s $(TARGET) $(BUILD_ROOT)$(BIN_DIR)
++ $(INSTALL) -m 755 $(TARGET) $(BUILD_ROOT)$(BIN_DIR)
+
+ tarball:
+ $(INSTALL) -d -m 755 ./$(PACKAGE_NAME)-$(PACKAGE_VERSION)