summaryrefslogtreecommitdiff
path: root/app-text/gspell
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /app-text/gspell
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'app-text/gspell')
-rw-r--r--app-text/gspell/Manifest2
-rw-r--r--app-text/gspell/gspell-1.6.1.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/app-text/gspell/Manifest b/app-text/gspell/Manifest
index cdde5cca36b6..dbcf0a47ddb7 100644
--- a/app-text/gspell/Manifest
+++ b/app-text/gspell/Manifest
@@ -1,3 +1,5 @@
DIST gspell-1.4.2.tar.xz 407356 BLAKE2B f2ee6ae43be55e8ad7253e10893868a8d7857bbe41e14d71103b27a0faf40b0ed247e9fa38ed7bc75039fe0f1f600fe739f538d50f69fb063d0932df6c0b1c27 SHA512 00f53d3ca47a4ba1af1e8b4983a41dc6df8a9788898b45ffdd161a3fc8de28024cc985f49fbb872912c0a94addbca3b28ce2edda70eeb206a794e2bcf65e4a5e
+DIST gspell-1.6.1.tar.xz 416704 BLAKE2B 2a180bc52d3f09813d8de362e5bf900f831663c09530c8a9b993baf55f852a3939447a71c9c9dc0caafba7e8b74a2a5aad4443cf248eb87da4e15e0481e74262 SHA512 f1ffbd0d23d9743bcf924c25b3a3d7bf93c6a5e4ea5e362fb7300f657d8c1d0117e847f3dec29de377947f850e003b24a3231e88e99b313c955dd94ce358c23e
EBUILD gspell-1.4.2.ebuild 984 BLAKE2B 34d49bf58ed3d59cbb94f95739fa8e03985f3e93be328251e5f1a080ea2e0eec734e9ab036e096f37c873da24c4fdea98c09b98bb010d9c9fc7b455e6ef7ad74 SHA512 43c47b3b112301aa1876e805999bb1631f6add794a7ab68d5ba162f7d12b741fadf2486458294f4b2b5bfd78f3143d9f9ca16631ba8020aad92ff1fbefc2cd92
+EBUILD gspell-1.6.1.ebuild 1006 BLAKE2B 411c9733da9d9c1b391fa9b1870a3e5cfcba4e87ca7d7ed921c735568ae93e155164e2b014e20d9b0eaa64abb50e28541611308720b2653eb47b794808254505 SHA512 dd4c5aa2efeb64e726baf14d4797a06d344d9f3f3872eb6caa2fb300e4070d3c3ea7bde773b6474c4f253e907491504b88132a474ae46bfb7b814e9918740d9d
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/app-text/gspell/gspell-1.6.1.ebuild b/app-text/gspell/gspell-1.6.1.ebuild
new file mode 100644
index 000000000000..483713d17e13
--- /dev/null
+++ b/app-text/gspell/gspell-1.6.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="Spell check library for GTK+ applications"
+HOMEPAGE="https://wiki.gnome.org/Projects/gspell"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/1" # subslot = libgspell-1 soname version
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-fbsd"
+
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ app-text/iso-codes
+ >=app-text/enchant-1.6.0
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.20:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.42.0:= )
+ vala? ( $(vala_depend) )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2:2
+ >=dev-util/gtk-doc-am-1.25
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ virtx emake check
+}