summaryrefslogtreecommitdiff
path: root/app-text/grip/grip-4.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/grip/grip-4.2.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/grip/grip-4.2.0.ebuild')
-rw-r--r--app-text/grip/grip-4.2.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-text/grip/grip-4.2.0.ebuild b/app-text/grip/grip-4.2.0.ebuild
new file mode 100644
index 000000000000..26ce65a13626
--- /dev/null
+++ b/app-text/grip/grip-4.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 pypy{,3} python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Preview GitHub Markdown files like Readme locally before committing them"
+HOMEPAGE="https://github.com/joeyespo/grip"
+LICENSE="MIT"
+
+SLOT="0"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/docopt-0.6.2
+ >=dev-python/flask-0.10.1
+ >=dev-python/markdown-2.5.1
+ >=dev-python/path-and-address-1.0.0
+ >=dev-python/pygments-1.6
+ >=dev-python/requests-2.4.1
+"