summaryrefslogtreecommitdiff
path: root/app-text/gocr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-text/gocr
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-text/gocr')
-rw-r--r--app-text/gocr/Manifest2
-rw-r--r--app-text/gocr/gocr-0.52.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/app-text/gocr/Manifest b/app-text/gocr/Manifest
index 124330622898..68b3a87b3cca 100644
--- a/app-text/gocr/Manifest
+++ b/app-text/gocr/Manifest
@@ -1,3 +1,5 @@
DIST gocr-0.50.tar.gz 419209 BLAKE2B 232fe240d7a559cdd4408a3dba3768818aefbd8b2718c7ae40829d69ab79dd68293eb6adfc52e661f2f6cf1290ae9656c84d9d7a8fc20229c0942a8e18fb3b68 SHA512 36392516711d43f8561147684b6f4e22a450bc87f1cb30ceaab4a1821ac583ff5a3d25b3bbf1637f01bfb55366b45cc7d5086d1f29f006d615bb658d0e5faab9
+DIST gocr-0.52.tar.gz 445401 BLAKE2B 1f22f5377bb95053e3ab4ede074b3fceca4065f9ca0ede05a8023ebe807f41074f5ead84e133281e98be7f68f13b036dc759cccaf4a5688bf776f62f2de1970a SHA512 e2e6e690e7a32e32237c8b64b1a11719680c560592349df43f4b230f3c92bf324f98e473979b0913c42e33e8abbaf27952b6af173ea06eb5535878a9f608ce6d
EBUILD gocr-0.50.ebuild 1194 BLAKE2B f2d7b20dc9437bc249deb9c752c516e366245b7f5fc3aaa26ba428bb360cc81b9298412e5be996ad9fb16e3a54f7389564b0e65f6c929a4a0c9328b78e197867 SHA512 8ce80abb20a31d902076ae3408812cbabe6a7911301959a542e639cdfeffdd51940d8a54aab5da71a035fabf7a8e0ce4a7fe27568c623a361e0dda0573eb41a0
+EBUILD gocr-0.52.ebuild 1199 BLAKE2B f7e32eead75ee686c1c7a1dca38e4929c0d24834121b87c9e94202c9d7efb23e3057abda259c7ef9db75145e2971f4b9e18a092f8bd47829cfe852abd36c4063 SHA512 cd651aaf4810346d1fef811e6c52ff59451daf5426b8e80c322e1074def566e63e7c6b0cd55fa8cdfcdc6ecce9a3b2c227a7b2519b928b086ce1254efb27c63c
MISC metadata.xml 241 BLAKE2B 0ddb3befa9aa8922cec51c1c82d2927a12fa35eab2474330dd53794dabb7dd58859fc35f02e7b5067111bb9838592f9976fe3ff343aae7f521cdc034cf165a4b SHA512 c0dbe231483dc9dfc42dfe465aa2202145bae8a1ac5794ef9a9f02f687275c525a7826740e3b35fee93ba856ff2a78b214956b02cece209f6322ee3311cbf0ec
diff --git a/app-text/gocr/gocr-0.52.ebuild b/app-text/gocr/gocr-0.52.ebuild
new file mode 100644
index 000000000000..cced5ddc3583
--- /dev/null
+++ b/app-text/gocr/gocr-0.52.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="An OCR (Optical Character Recognition) reader"
+HOMEPAGE="http://jocr.sourceforge.net"
+SRC_URI="http://www-e.uni-magdeburg.de/jschulen/ocr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc scanner tk"
+
+DEPEND="
+ >=media-libs/netpbm-9.12
+ doc? (
+ >=media-gfx/transfig-3.2
+ app-text/ghostscript-gpl
+ )
+ tk? ( dev-lang/tk )"
+RDEPEND="${DEPEND}
+ tk? (
+ media-gfx/xli
+ scanner? ( media-gfx/xsane )
+ )"
+
+src_compile() {
+ local targets=( src man )
+ use doc && targets+=( doc examples )
+
+ emake "${targets[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" exec_prefix="${EPREFIX}/usr" install
+ einstalldocs
+ dodoc HISTORY REMARK.txt REVIEW
+
+ # remove the tk frontend if tk is not selected
+ if ! use tk; then
+ rm "${ED}"/usr/bin/gocr.tcl || die
+ fi
+
+ # and install the documentation and examples
+ if use doc; then
+ dodoc doc/gocr.html doc/examples.txt doc/unicode.txt
+
+ docinto examples
+ dodoc examples/*.{fig,tex,pcx}
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}