summaryrefslogtreecommitdiff
path: root/app-text/gocr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-13 10:28:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-13 10:28:51 +0000
commitaafdd1dcd9a66da0b1bcdfadbca62add48751897 (patch)
treed328a4fe625235ee8ea443c3b1bec1fd105af11d /app-text/gocr
parente0345ef79b0b4a444151748ce1f5364fc2dd147b (diff)
gentoo auto-resync : 13:11:2023 - 10:28:51
Diffstat (limited to 'app-text/gocr')
-rw-r--r--app-text/gocr/Manifest1
-rw-r--r--app-text/gocr/gocr-0.52-r1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-text/gocr/Manifest b/app-text/gocr/Manifest
index b4fdf3b823eb..088dbaec2947 100644
--- a/app-text/gocr/Manifest
+++ b/app-text/gocr/Manifest
@@ -1,3 +1,4 @@
DIST gocr-0.52.tar.gz 445401 BLAKE2B 1f22f5377bb95053e3ab4ede074b3fceca4065f9ca0ede05a8023ebe807f41074f5ead84e133281e98be7f68f13b036dc759cccaf4a5688bf776f62f2de1970a SHA512 e2e6e690e7a32e32237c8b64b1a11719680c560592349df43f4b230f3c92bf324f98e473979b0913c42e33e8abbaf27952b6af173ea06eb5535878a9f608ce6d
+EBUILD gocr-0.52-r1.ebuild 1220 BLAKE2B f4ffe43a3592c105cf04ca302bd9a865d038fcfd5ca1848a01f6ded252c72c6672f1dd02c0d9336bb6d9d9d163d940a92f6133da4ee54ef18a4a631a0584e1e8 SHA512 695bdbdf77cf924550b1719da43505645030eefffcc635d7394042d40dda75d4f99f3aa870ab23fe12d8617d117723f777898f2b0e1fa32ee4ebd85aeedab988
EBUILD gocr-0.52.ebuild 1211 BLAKE2B 48d4d36a5f68ce119bb81f9c370bbe61f712a33fe94adf838b5bd37433dccf541888354e6e6b5c9097fc2c2e9e40aaa50cebafe38f403c3af93d7b37dd199968 SHA512 f2d02906a4c3382c602bc020d6365f2ea0ef19370efc7005764afba01714c52122305620cb4e11eb2077a62a2a84fa030325ab62c62d84f374a8e22513f5d984
MISC metadata.xml 242 BLAKE2B 6d6452effca096b9ddfe9cf937bae671b0395d8757aa1c6e56be35d80495d6d6ad96c992c297191853da2e915094175cfc63d7ff74eab76885d5641ecb2c6632 SHA512 e0ecf1bfae6c474b11ceb51240d5cce9978c17adc03c606327ae7086bfc55ef20da3934c25ab4ecef4dfd4db63f73f5ccb44670c5e860357eb4da1af2eb2d02f
diff --git a/app-text/gocr/gocr-0.52-r1.ebuild b/app-text/gocr/gocr-0.52-r1.ebuild
new file mode 100644
index 000000000000..c598b8bc26bd
--- /dev/null
+++ b/app-text/gocr/gocr-0.52-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="An OCR (Optical Character Recognition) reader"
+HOMEPAGE="https://www-e.uni-magdeburg.de/jschulen/ocr/"
+SRC_URI="http://www-e.uni-magdeburg.de/jschulen/ocr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc scanner tk"
+
+DEPEND="
+ >=media-libs/netpbm-9.12
+ doc? (
+ >=media-gfx/fig2dev-3.2.9-r1
+ app-text/ghostscript-gpl
+ )
+ tk? ( dev-lang/tk )"
+RDEPEND="${DEPEND}
+ tk? (
+ media-gfx/xli
+ scanner? ( media-gfx/xsane )
+ )"
+
+src_compile() {
+ local targets=( src man )
+ use doc && targets+=( doc examples )
+
+ emake "${targets[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" exec_prefix="${EPREFIX}/usr" install
+ einstalldocs
+ dodoc HISTORY REMARK.txt REVIEW
+
+ # remove the tk frontend if tk is not selected
+ if ! use tk; then
+ rm "${ED}"/usr/bin/gocr.tcl || die
+ fi
+
+ # and install the documentation and examples
+ if use doc; then
+ dodoc doc/gocr.html doc/examples.txt doc/unicode.txt
+
+ docinto examples
+ dodoc examples/*.{fig,tex,pcx}
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}