summaryrefslogtreecommitdiff
path: root/app-text/getxbook/files/getxbook-1.2.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/getxbook/files/getxbook-1.2.patch
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/getxbook/files/getxbook-1.2.patch')
-rw-r--r--app-text/getxbook/files/getxbook-1.2.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/getxbook/files/getxbook-1.2.patch b/app-text/getxbook/files/getxbook-1.2.patch
new file mode 100644
index 000000000000..da0ac83264e1
--- /dev/null
+++ b/app-text/getxbook/files/getxbook-1.2.patch
@@ -0,0 +1,35 @@
+diff -r -U2 getxbook-1.2.orig/Makefile getxbook-1.2/Makefile
+--- getxbook-1.2.orig/Makefile 2015-07-28 21:52:40.000000000 +0600
++++ getxbook-1.2/Makefile 2017-12-16 11:27:18.554822718 +0700
+@@ -1,4 +1,13 @@
+ # See COPYING file for copyright and license details.
+-include config.mk
++VERSION = 1.2
++RELDATE = 2015-07-28
++PREFIX = /usr
++MANPREFIX = $(PREFIX)/share/man
++CFLAGS += -std=c99 -pedantic -Wall -Wextra -Werror -g -D_POSIX_C_SOURCE=200112L \
++ -DVERSION=\"$(VERSION)\"
++CC ?= cc
++LD = $(CC)
++LIBS = -lssl -lcrypto
++LDFLAGS += $(LIBS)
+
+ NAME = getxbook
+@@ -21,13 +30,13 @@
+ .o:
+ @echo LD $@
+- @$(LD) -o $@ $< util.a $(LDFLAGS)
++ $(LD) -o $@ $< util.a $(LDFLAGS)
+
+ .c.o:
+ @echo CC $<
+- @$(CC) -c $(CFLAGS) $<
++ $(CC) -c $(CFLAGS) $<
+
+ util.a: $(LIB)
+ @echo AR $@
+- @$(AR) -r -s -c $@ $(LIB)
++ $(AR) -r -s -c $@ $(LIB)
+
+ install: all