summaryrefslogtreecommitdiff
path: root/app-text/fbpdf/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/fbpdf/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/fbpdf/files')
-rw-r--r--app-text/fbpdf/files/fbpdf-0_p20161202-format.patch14
-rw-r--r--app-text/fbpdf/files/fbpdf-0_p20161202-mupdfthird.patch9
2 files changed, 23 insertions, 0 deletions
diff --git a/app-text/fbpdf/files/fbpdf-0_p20161202-format.patch b/app-text/fbpdf/files/fbpdf-0_p20161202-format.patch
new file mode 100644
index 000000000000..0b48d6bff020
--- /dev/null
+++ b/app-text/fbpdf/files/fbpdf-0_p20161202-format.patch
@@ -0,0 +1,14 @@
+diff --git a/fbpdf.c b/fbpdf.c
+index 6caa08f..48d12f5 100644
+--- a/fbpdf.c
++++ b/fbpdf.c
+@@ -343,3 +343,3 @@ static void mainloop(void)
+ static char *usage =
+- "usage: fbpdf [-r rotation] [-z zoom x10] [-p page] filename\n";
++ "usage: fbpdf [-r rotation] [-z zoom x10] [-p page] filename";
+
+@@ -349,3 +349,3 @@ int main(int argc, char *argv[])
+ if (argc < 2) {
+- printf(usage);
++ puts(usage);
+ return 1;
diff --git a/app-text/fbpdf/files/fbpdf-0_p20161202-mupdfthird.patch b/app-text/fbpdf/files/fbpdf-0_p20161202-mupdfthird.patch
new file mode 100644
index 000000000000..070b7c72ea26
--- /dev/null
+++ b/app-text/fbpdf/files/fbpdf-0_p20161202-mupdfthird.patch
@@ -0,0 +1,9 @@
+diff --git a/Makefile b/Makefile
+index f986689..374837f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -13,3 +13,3 @@ clean:
+ fbpdf: fbpdf.o mupdf.o draw.o
+- $(CC) -o $@ $^ $(LDFLAGS) -lmupdf -lmupdfthird -lcrypto -lm
++ $(CC) -o $@ $^ $(LDFLAGS) -lmupdf -lcrypto -lm
+