summaryrefslogtreecommitdiff
path: root/app-text/extract_url/extract_url-1.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/extract_url/extract_url-1.6.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/extract_url/extract_url-1.6.2.ebuild')
-rw-r--r--app-text/extract_url/extract_url-1.6.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-text/extract_url/extract_url-1.6.2.ebuild b/app-text/extract_url/extract_url-1.6.2.ebuild
new file mode 100644
index 000000000000..8ccadeb5e0f5
--- /dev/null
+++ b/app-text/extract_url/extract_url-1.6.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="extracts URLs from correctly-encoded MIME email messages or plain text"
+HOMEPAGE="https://www.memoryhole.net/~kyle/extract_url/ https://github.com/m3m0ryh0l3/extracturl/"
+SRC_URI="https://github.com/m3m0ryh0l3/${PN/_/}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-perl/MIME-tools
+ dev-perl/HTML-Parser
+ dev-perl/URI-Find
+ dev-perl/Curses-UI
+ dev-perl/TermReadKey
+"
+
+S=${WORKDIR}/${P/_/}
+
+src_install() {
+ default
+ dodoc extract_urlview.sample
+}