summaryrefslogtreecommitdiff
path: root/app-text/expander/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/expander/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/expander/files')
-rw-r--r--app-text/expander/files/expander-2.0.5-gentoo.patch58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-text/expander/files/expander-2.0.5-gentoo.patch b/app-text/expander/files/expander-2.0.5-gentoo.patch
new file mode 100644
index 000000000000..460a8164cee5
--- /dev/null
+++ b/app-text/expander/files/expander-2.0.5-gentoo.patch
@@ -0,0 +1,58 @@
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -3,15 +3,14 @@
+ bindir = $(BINDIR)/
+
+ copy = ln -fs
+-CFLAGS += -v -g # -DNEED_GETOPT_PROTO_TYPE
+-compiler = cc $(CFLAGS)
++compiler = $(CC) $(CFLAGS)
+
+ executables = expander boxcomment align_columns align_comments where_is
+
+ #--------------
+ # Build Targets
+ #--------------
+-all: verify $(executables)
++all: $(executables)
+
+ verify:
+ @if [ "$(bindir)" = "/" ]; then \
+@@ -24,32 +23,31 @@
+ # Abbreviation expansion filter program (with NEdit, language sensitive)
+ #-----------------------------------------------------------------------
+ expander: expander.c
+- $(compiler) -o $(bindir)$@ $?
++ $(compiler) $(LDFLAGS) -o $@ $?
+
+ #--------------------------------------------------------------------------
+ # Surround given text with open ended box. (with NEdit, language sensitive)
+ #--------------------------------------------------------------------------
+ boxcomment: boxcomment.c
+- $(compiler) -o $(bindir)$@ $?
+- @if [ ! -f $(bindir)un$@ ]; then $(copy) $(bindir)$@ $(bindir)un$@; fi
++ $(compiler) $(LDFLAGS) -o $@ $?
+
+ #-------------------------------------------------------------------------------
+ # Align ragged looking 'C' style comments (good substitute for align_equals too)
+ #-------------------------------------------------------------------------------
+ align_comments: align_comments.c
+- $(compiler) -o $(bindir)$@ $?
++ $(compiler) $(LDFLAGS) -o $@ $?
+
+ #----------------------------
+ # Align given text in columns
+ #----------------------------
+ align_columns: align_columns.c
+- $(compiler) -o $(bindir)$@ $?
++ $(compiler) $(LDFLAGS) -o $@ $?
+
+ #----------------------------------------------
+ # File locator (substitute for which, where...)
+ #----------------------------------------------
+ where_is: where_is.c
+- $(compiler) -o $(bindir)$@ $?
++ $(compiler) $(LDFLAGS) -o $@ $?
+
+ #------------------------------------------------
+ # Here is how to uninstall the executables built.