summaryrefslogtreecommitdiff
path: root/app-text/evince/files/40.1-build-Fix-t1lib-detection.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /app-text/evince/files/40.1-build-Fix-t1lib-detection.patch
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'app-text/evince/files/40.1-build-Fix-t1lib-detection.patch')
-rw-r--r--app-text/evince/files/40.1-build-Fix-t1lib-detection.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-text/evince/files/40.1-build-Fix-t1lib-detection.patch b/app-text/evince/files/40.1-build-Fix-t1lib-detection.patch
new file mode 100644
index 000000000000..5e46649e2536
--- /dev/null
+++ b/app-text/evince/files/40.1-build-Fix-t1lib-detection.patch
@@ -0,0 +1,30 @@
+From bb3c826f134c47c505ad4fd93b1c97f67da5350c Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Mon, 12 Apr 2021 23:47:14 -0400
+Subject: [PATCH] build: Fix t1lib detection
+
+Without this, Meson always fails to detect t1lib. Autotools looked for
+the correct function name. See the check at the time of removal in
+commit b27189bb ("build: Remove autotools")
+
+Fixes: d69158ec ("build: Port to Meson build system")
+---
+ meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index abee124d..0d7fd4d4 100644
+--- a/meson.build
++++ b/meson.build
+@@ -365,7 +365,7 @@ if enable_dvi
+ endforeach
+
+ t1_dep = cc.find_library('t1', required: get_option('t1lib'))
+- enable_t1lib = t1_dep.found() and cc.has_function('T1_initLib', dependencies: t1_dep)
++ enable_t1lib = t1_dep.found() and cc.has_function('T1_InitLib', dependencies: t1_dep)
+ config_h.set('WITH_TYPE1_FONTS', enable_t1lib)
+
+ backends += {'dvi': mime_types_list.get('dvi')}
+--
+2.26.3
+