summaryrefslogtreecommitdiff
path: root/app-text/epstool/epstool-3.08-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/epstool/epstool-3.08-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/epstool/epstool-3.08-r1.ebuild')
-rw-r--r--app-text/epstool/epstool-3.08-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-text/epstool/epstool-3.08-r1.ebuild b/app-text/epstool/epstool-3.08-r1.ebuild
new file mode 100644
index 000000000000..04ef4ccd4060
--- /dev/null
+++ b/app-text/epstool/epstool-3.08-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Creates or extracts preview images in EPS files, fixes bounding boxes"
+HOMEPAGE="http://www.cs.wisc.edu/~ghost/gsview/epstool.htm"
+SRC_URI="ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/ghostgum/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="app-text/ghostscript-gpl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/gcc43.patch
+
+ sed -i \
+ -e '/^CC/s/=/?=/' \
+ -e '/^CLINK/s/gcc/$(CC)/' \
+ src/unixcom.mak || die
+ tc-export CC
+
+ epatch_user
+
+ # parallel make issue (bug #506978)
+ mkdir bin || die
+ mkdir epsobj || die
+}
+
+src_compile() {
+ emake epstool
+}
+
+src_install() {
+ dobin bin/epstool
+ doman doc/epstool.1
+ dohtml doc/epstool.htm doc/gsview.css
+}