summaryrefslogtreecommitdiff
path: root/app-text/enchant/enchant-2.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/enchant/enchant-2.1.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/enchant/enchant-2.1.2.ebuild')
-rw-r--r--app-text/enchant/enchant-2.1.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-text/enchant/enchant-2.1.2.ebuild b/app-text/enchant/enchant-2.1.2.ebuild
new file mode 100644
index 000000000000..0780c2cc403d
--- /dev/null
+++ b/app-text/enchant/enchant-2.1.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Spellchecker wrapping library"
+HOMEPAGE="https://abiword.github.io/enchant/"
+SRC_URI="https://github.com/AbiWord/enchant/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+
+IUSE="aspell +hunspell static-libs test"
+REQUIRED_USE="|| ( hunspell aspell )"
+
+# FIXME: depends on unittest++ but through pkgconfig which is a Debian hack, bug #629742
+COMMON_DEPENDS="
+ >=dev-libs/glib-2.6:2
+ aspell? ( app-text/aspell )
+ hunspell? ( >=app-text/hunspell-1.2.1:0= )"
+
+RDEPEND="${COMMON_DEPENDS}"
+
+DEPEND="${COMMON_DEPENDS}
+ virtual/pkgconfig
+"
+# test? ( dev-libs/unittest++ )
+
+RESTRICT="test"
+
+src_configure() {
+ econf \
+ $(use_with aspell) \
+ $(use_with hunspell) \
+ $(use_enable static-libs static) \
+ --without-hspell \
+ --without-voikko \
+ --with-hunspell-dir="${EPREFIX}"/usr/share/hunspell/
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}