summaryrefslogtreecommitdiff
path: root/app-text/dvipng/dvipng-1.17.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /app-text/dvipng/dvipng-1.17.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'app-text/dvipng/dvipng-1.17.ebuild')
-rw-r--r--app-text/dvipng/dvipng-1.17.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-text/dvipng/dvipng-1.17.ebuild b/app-text/dvipng/dvipng-1.17.ebuild
new file mode 100644
index 000000000000..8143ed496cef
--- /dev/null
+++ b/app-text/dvipng/dvipng-1.17.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Translate DVI files into PNG or GIF graphics"
+HOMEPAGE="http://dvipng.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+ Texinfo-manual"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="truetype test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/kpathsea-6.2.1:=
+ media-libs/gd:2=[jpeg,png]
+ media-libs/libpng:0=
+ virtual/latex-base
+ sys-libs/zlib
+ truetype? ( >=media-libs/freetype-2.1.5 )"
+DEPEND="${RDEPEND}
+ virtual/texi2dvi
+ virtual/pkgconfig
+ test? ( dev-texlive/texlive-fontsrecommended )"
+
+DOCS="ChangeLog README RELEASE"
+S="${WORKDIR}"
+
+src_configure() {
+ append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
+ if ! use truetype; then
+ sed -i -e 's/\(--exists.*\)freetype2/\1dIsAbLe/' configure \
+ || die "sed failed"
+ fi
+
+ export VARTEXFONTS="${T}/fonts"
+ econf
+}