summaryrefslogtreecommitdiff
path: root/app-text/duali
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/duali
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/duali')
-rw-r--r--app-text/duali/Manifest3
-rw-r--r--app-text/duali/duali-0.2.0-r1.ebuild40
-rw-r--r--app-text/duali/metadata.xml8
3 files changed, 51 insertions, 0 deletions
diff --git a/app-text/duali/Manifest b/app-text/duali/Manifest
new file mode 100644
index 000000000000..fc94bcfb9aaa
--- /dev/null
+++ b/app-text/duali/Manifest
@@ -0,0 +1,3 @@
+DIST duali-0.2.0.tar.bz2 13334 BLAKE2B 28366eedef3c37d40b88c1458cbc420be6dd44b252bd7b176939f1d794ef29659109d19bb7328388b6ef3e16ba8dc0c500fd962525b3e05c44900092687f5cd2 SHA512 9234647b722a54fce8f947f2f0eb8cc121e5bdd32bcf606bc8ff71854eaf68655474e374b3328b2a20af58484e5962dadf716bc220f7fd697a8cfbb99afb2d30
+EBUILD duali-0.2.0-r1.ebuild 946 BLAKE2B 78caa7e0559bdb52769781be9b23d1ae5632a1d7e281444b13a005ec26b744a78e128aeaf7791c01c751890af57dc70186a862e364d71632b7bd0bd96df7802c SHA512 76f7b3f2cef67e6e6c46c93e9f4fbac440a7fe0d4ff4d34e276d3ba918868d6c7c2750f6bb09226ee33950888b1853705daed2ef46f5c447c60163dd7fbd3762
+MISC metadata.xml 245 BLAKE2B 7dc5df660e9e3cc71fcd39abbcc77edc7890bd44fa6e2d68556b914e6a35c6e6526e281b6aa286a0f12893a527669c2fbf64d63c8ad555137e222832edaf2cc1 SHA512 5cf81ad67c841f8eb5a71ef18b6ae6c344d68fb63c80c21f4a9b9a0060de938264530276a152eb5451dd88a5955f04a48c8cd4d034be6bc7a1922b5e4f43539f
diff --git a/app-text/duali/duali-0.2.0-r1.ebuild b/app-text/duali/duali-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..4eb15157f591
--- /dev/null
+++ b/app-text/duali/duali-0.2.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+# Duali uses "anydbm" which should even support a slow fallback;
+# however, due to implementation details it fails when the databases
+# aren't gdbm.
+PYTHON_REQ_USE="gdbm"
+
+inherit python-single-r1
+
+DESCRIPTION="Arabic dictionary based on the DICT protocol"
+HOMEPAGE="https://www.arabeyes.org/Duali"
+SRC_URI="mirror://sourceforge/arabeyes/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ~ia64 ~mips ~ppc ~sparc x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+PDEPEND=">=app-dicts/duali-data-0.1b-r1"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_install() {
+ python_fix_shebang duali dict2db trans2arabic arabic2trans
+ python_doexe duali dict2db trans2arabic arabic2trans
+
+ insinto /etc
+ doins duali.conf
+
+ doman doc/man/*.1
+ dodoc README ChangeLog
+
+ python_domodule pyduali
+}
diff --git a/app-text/duali/metadata.xml b/app-text/duali/metadata.xml
new file mode 100644
index 000000000000..c8c6479d60fe
--- /dev/null
+++ b/app-text/duali/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="sourceforge">arabeyes</remote-id>
+ </upstream>
+</pkgmetadata>