summaryrefslogtreecommitdiff
path: root/app-text/doconce/doconce-1.4.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/doconce/doconce-1.4.4.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/doconce/doconce-1.4.4.ebuild')
-rw-r--r--app-text/doconce/doconce-1.4.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-text/doconce/doconce-1.4.4.ebuild b/app-text/doconce/doconce-1.4.4.ebuild
new file mode 100644
index 000000000000..8752b80e9b24
--- /dev/null
+++ b/app-text/doconce/doconce-1.4.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+inherit distutils-r1
+
+DESCRIPTION="A markdown-like langauge to generate docs in html, LaTeX, and many other formats"
+HOMEPAGE="https://github.com/hplgit/doconce/ https://pypi.org/project/Doconce/"
+SRC_URI="https://dev.gentoo.org/~grozin/${P}.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc"
+KEYWORDS="~amd64 ~x86"
+RDEPEND="dev-python/future[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_install() {
+ default
+ if use doc; then
+ sed -e "s|http://hplgit.github.io/doconce/doc|file:///usr/share/doc/${PF}|g" -i doc/web/index.html
+ docompress -x /usr/share/doc
+ dodoc -r doc/web doc/pub
+ fi
+}