summaryrefslogtreecommitdiff
path: root/app-text/discount
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
commitc3bc61051d7f12b4c682efa7a5460bbc8815649e (patch)
treeb6d19e96ba3c397fb8278eeb9b68170db92630ba /app-text/discount
parent3517852e3b8a68d1e997770fc0650c5053bafc6c (diff)
gentoo resync : 07.01.2022
Diffstat (limited to 'app-text/discount')
-rw-r--r--app-text/discount/Manifest1
-rw-r--r--app-text/discount/discount-2.2.7-r1.ebuild69
2 files changed, 0 insertions, 70 deletions
diff --git a/app-text/discount/Manifest b/app-text/discount/Manifest
index 72b07f66e590..17fdf894c646 100644
--- a/app-text/discount/Manifest
+++ b/app-text/discount/Manifest
@@ -1,5 +1,4 @@
AUX gethopt-undefined.patch 358 BLAKE2B ccc264eece330bc0c8979731410488b070c91e73381ed4f00ff95f04c5f023948f304dd70c0f8ec4ff67abf266d80ce8931fa46f53486e2e0e003f151fbda4b7 SHA512 a7504f3ab60ff49b72e475e558e128522757874d4328abf7e488313dff7c2fc3650fffc12a03109601a14348f24f21a83ed0e83f9d6fe1176207ac2692800dc1
DIST discount-2.2.7.tar.bz2 102277 BLAKE2B 58ec3bce2b8fc41a090d9b81b4326cbf54e36bf774f4f9ef63c2a2b1d34ba464e9f0a021f19b4fef165da426742af3045a631af005371d1a8a4cd81dc0be3367 SHA512 1b61eb7c625bb50da0dbe97350a0ccbb15930ccaef449c4b4659950907bce3c0564dabf20578379a7fdd0e375f5d4d5b61acd34db474a85e942b60373688bd08
-EBUILD discount-2.2.7-r1.ebuild 1690 BLAKE2B 710bd40dc677328a0f8aaa6ad3a387d75fe939b289186d889f35002c08c82b52bfaa5fe138816eb7ecdbfd6ec437b863df0c248448cd99e92452a2cafeb995a1 SHA512 27008019ccf6fb42d7e364990baa6facb7f0c8d8e40375dcc44594ccef7c792648f8d1dcd6c69a895c5a059c3799722d43338bbbc1c443dc284433ac0da4156d
EBUILD discount-2.2.7-r2.ebuild 1697 BLAKE2B f6a68291682e44d6adfa9fdb40fe7e1c1bbac2c0981fd86f223344053c6510b27b4c734613c0acc4f29b31f5ffc862924ceaeda442fc7a52f27f111d6ce7e882 SHA512 cd1653e485b7785f630017210eb5268ac7c42c362cd95e2bea38f977f99c79cfd3aef8c35aa292d6764868f404bb74f77b068596a3b17c7001488c7a0c761308
MISC metadata.xml 245 BLAKE2B 4988fa1366a9b8a3769e503545339cdd493a0bdc362ca9237b158b94549de1f061477546b00fd3b21dc9325812423f7207071e22e3234d5c0b88c755197557d2 SHA512 e00be68ab9ad3acfce3d2d48721c47cf50e2c6358c9ceb45a2a23fc5303826ea26b9205ce4f230121c2e40c9c467367f2dc57863680899b21e8005034aa9118c
diff --git a/app-text/discount/discount-2.2.7-r1.ebuild b/app-text/discount/discount-2.2.7-r1.ebuild
deleted file mode 100644
index 1ecc2092dae3..000000000000
--- a/app-text/discount/discount-2.2.7-r1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="A Markdown-to HTML translator written in C"
-HOMEPAGE="http://www.pell.portland.or.us/~orc/Code/discount/"
-SRC_URI="http://www.pell.portland.or.us/~orc/Code/${PN}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ppc ppc64 sparc x86"
-IUSE="minimal test"
-RESTRICT="!test? ( test )"
-
-PATCHES=( "${FILESDIR}"/gethopt-undefined.patch )
-
-src_prepare() {
- default
-
- # for QA, we remove the Makefile’s usage of install -s.
- # Drop ldconfig invocation.
- # Force “librarian.sh” to respect LDFLAGS ($FLAGS should have CFLAGS
- # at that point).
- sed -i \
- -e '/INSTALL_PROGRAM/s,\$_strip ,,' \
- -e 's/\(LDCONFIG=\).*/\1:/' \
- -e 's/\(.\)\$FLAGS/& \1$LDFLAGS/' \
- configure.inc || die "sed configure.inc failed"
-}
-
-src_configure() {
- local configure_call=(
- ./configure.sh
- --libdir="${EPREFIX}/usr/$(get_libdir)"
- --prefix="${EPREFIX}/usr"
- --mandir="${EPREFIX}/usr/share/man"
- --shared
- --pkg-config
- $(usex minimal '' --enable-all-features)
- # Enable deterministic HTML generation behavior. Otherwise, will
- # actually call rand() as part of its serialization code...
- --debian-glitch
- )
- einfo "Running ${configure_call[@]}"
- CC="$(tc-getCC)" AR="$(tc-getAR)" \
- "${configure_call[@]}" || die
-}
-
-src_compile() {
- emake libmarkdown
- emake
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- $(usex minimal install install.everything) \
- SAMPLE_PFX="${PN}-"
-}
-
-pkg_postinst() {
- if ! use minimal; then
- elog 'Sample binaries with overly-generic names have been'
- elog "prefixed with \"${PN}-\"."
- fi
-}