summaryrefslogtreecommitdiff
path: root/app-text/discount
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/discount
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/discount')
-rw-r--r--app-text/discount/Manifest7
-rw-r--r--app-text/discount/discount-2.1.8a-r1.ebuild77
-rw-r--r--app-text/discount/discount-2.2.2.ebuild70
-rw-r--r--app-text/discount/discount-2.2.3a.ebuild70
-rw-r--r--app-text/discount/metadata.xml12
5 files changed, 236 insertions, 0 deletions
diff --git a/app-text/discount/Manifest b/app-text/discount/Manifest
new file mode 100644
index 000000000000..0dd6def1b539
--- /dev/null
+++ b/app-text/discount/Manifest
@@ -0,0 +1,7 @@
+DIST discount-2.1.8a.tar.bz2 85161 BLAKE2B 15b2f3e935115e6b9f2c4ba1c11b1d6ea6f32123bd11c1e13dcab7fd9badac9a4f7d671c0cf04a6dd9564e40fbd6970f26c473c188444db75e0ee6b91a1ed1bc SHA512 a1eba7076a27da56136b8057189c5474a36bf11f8233cbae270c8a0cf9b070332b4dcdbbbecfbfbe1d8c19961ccaf87cee27ebe855c6bc6558d8ccc423553c96
+DIST discount-2.2.2.tar.bz2 89288 BLAKE2B 43950b3000f4d6e30603562694e965518be10107e534f48592f7f2d62959778244193fe5ab788f7f697bb099bb1ac940948ec92dabde1219a69bbe380eb5f66a SHA512 67d882c0a334592230332815c543458b3c916a950bf7983f8a468fbc9f61154b4023d4bf451b76639fcb3a076506b48118f192a8e21f2535b3f49c7f081bbdf3
+DIST discount-2.2.3a.tar.bz2 98325 BLAKE2B b566a6f4d5a1f3481a0a665f7820508784b2ce6ec60d0b4ff833bed46c01a9a6bf6a697fc528bcddd37232246982e861a89733bf6654cedecc95a09def729463 SHA512 cf995a46879f269f3e02f7d480303d229676bb36f71fe045d3a8eab7306fca9cce98496611b9fb9e0a14a9cf46ee66bd239dd9c946dff54ae09277fd66459c1f
+EBUILD discount-2.1.8a-r1.ebuild 2429 BLAKE2B 505a9c2e3d1ce65860a082d28564a9163cf8fa9edd9b9fbdade27e5a0c15bd66eab611296355f70623504636355f25ba83e997b05dfaa24667a26fc87742513e SHA512 065784f0effb3c1c24ba3b7897022480c956aa07a1288e047fb5e1a2fb51a347a7950f5ea09b4af2ef01222021297b4a8744fac70d07532651af978aebfe6118
+EBUILD discount-2.2.2.ebuild 1790 BLAKE2B fad3324fbb2c6894382d61f0bc36fdc2c058bacafebecb0c3f5e8b4383a8cb26258c2f31bf4ff4d22278bb1b6fe895ff3962214f18175b0adcfab3f71081a58c SHA512 a69861b85f1f2b30dfcbb08892ee4daa00fd4792536a9b90ff43e067d22f8f2716502d51e234e698eb09f4aa472bb68fb648083bfa1406abc29eba2f3239e989
+EBUILD discount-2.2.3a.ebuild 1796 BLAKE2B 537be30783469388cb353298bca0117956ad4916f7a613dbcf4d7466fea55e254cefeaf2abfe997715a267775f3d33f318389129997d474695d4ac58115312ae SHA512 be991bd13812130598e4231c5ca5ffdbe59a19baabf926f86adf571361e09f6d2e8da19690fb9b4b94315e7c997072ae31d6aa00f47cdcd7d8c7a13047d53f8b
+MISC metadata.xml 366 BLAKE2B 2e5fe0a3c428627cc1feb2aee974a537b8244ea9029ed6830b809c110d057a65535684032e830a42dff47852b632dc7c74473294f2eb2c7cd9789be3d27bd87f SHA512 39d05813a4efdcd14d0f5932efc63c25ae22b83088cb1bf020863e8ab9bdb348bcbd48901a2dff3c1184dc1483ae3868d2b4a2fd942dda91150944008773db3f
diff --git a/app-text/discount/discount-2.1.8a-r1.ebuild b/app-text/discount/discount-2.1.8a-r1.ebuild
new file mode 100644
index 000000000000..f913f6fad1fc
--- /dev/null
+++ b/app-text/discount/discount-2.1.8a-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils multilib
+
+DESCRIPTION="An implementation of John Gruber's Markdown text to html language written in C"
+HOMEPAGE="http://www.pell.portland.or.us/~orc/Code/discount/"
+SRC_URI="http://www.pell.portland.or.us/~orc/Code/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
+IUSE="minimal"
+
+src_prepare() {
+ # for QA, we remove the Makefile’s usage of install -s.
+ # Drop ldconfig invocation.
+ # Force “librarian.sh” to respect LDFLAGS ($FLAGS should have CFLAGS
+ # at that point).
+ sed -i \
+ -e '/INSTALL_PROGRAM/s,-s ,,' \
+ -e 's/\(LDCONFIG=\).*/\1:/' \
+ -e 's/\(.\)\$FLAGS/& \1$LDFLAGS/' \
+ configure.inc || die "sed configure.inc failed"
+
+ # Add LDFLAGS and CPPFLAGS hackily.
+ sed -i \
+ -e 's/^CC[ \t]*=.*/& $(CPPFLAGS)/' \
+ -e 's/^LFLAGS[ \t]*=.*/& $(LDFLAGS)/' \
+ Makefile.in || die "Cannot fix LDFLAGS and CPPFLAGS"
+}
+
+src_configure() {
+ # How econf() handles quoted whitespace. This should go away next
+ # release of discount.
+ eval "local -a DISCOUNT_EXTRA_CONFIGURE_SH=(${DISCOUNT_EXTRA_CONFIGURE_SH})"
+
+ local configure_call=(
+ ./configure.sh
+ --libdir="${EPREFIX}"usr/"$(get_libdir)"
+ --prefix="${EPREFIX}"usr
+ --mandir="${EPREFIX}"usr/share/man
+ --shared
+ $(usex minimal '' --enable-all-features)
+ # Because a lot of discount features are exposed through
+ # ./configure.sh flags that, in the future, won’t be, I will
+ # respect DISCOUNT_EXTRA_CONFIGURE_SH as a workaround pending
+ # upstream https://github.com/Orc/discount/issues/124 for bug
+ # #554520.
+ "${DISCOUNT_EXTRA_CONFIGURE_SH[@]}"
+ # Enable deterministic HTML generation behavior. Otherwise, will
+ # actually call rand() as parse of its serialization code…
+ --debian-glitch
+ )
+ einfo "Running ${configure_call[@]} || die"
+ "${configure_call[@]}" || die
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ $(usex minimal install install.everything) \
+ SAMPLE_PFX="${PN}-"
+}
+
+pkg_postinst() {
+ if ! use minimal; then
+ elog "Sample binaries with overly-generic names have been"
+ elog "prefixed with \"${PN}-\". Please see"
+ elog "https://github.com/Orc/discount/issues/81 for discussion."
+ fi
+ # This should also go away after 2.1.8a…
+ elog "To configure advanced options, use DISCOUNT_EXTRA_CONFIGURE_SH"
+ elog "and see https://bugs.gentoo.org/554520."
+}
diff --git a/app-text/discount/discount-2.2.2.ebuild b/app-text/discount/discount-2.2.2.ebuild
new file mode 100644
index 000000000000..bb4f809a591c
--- /dev/null
+++ b/app-text/discount/discount-2.2.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A Markdown-to HTML translator written in C"
+HOMEPAGE="http://www.pell.portland.or.us/~orc/Code/discount/"
+SRC_URI="http://www.pell.portland.or.us/~orc/Code/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="minimal test"
+
+src_prepare() {
+ default
+
+ # for QA, we remove the Makefile’s usage of install -s.
+ # Drop ldconfig invocation.
+ # Force “librarian.sh” to respect LDFLAGS ($FLAGS should have CFLAGS
+ # at that point).
+ sed -i \
+ -e '/INSTALL_PROGRAM/s,-s ,,' \
+ -e 's/\(LDCONFIG=\).*/\1:/' \
+ -e 's/\(.\)\$FLAGS/& \1$LDFLAGS/' \
+ configure.inc || die "sed configure.inc failed"
+
+ # Add LDFLAGS and CPPFLAGS hackily.
+ sed -i \
+ -e 's/^CC[ \t]*=.*/& $(CPPFLAGS)/' \
+ -e 's/^LFLAGS[ \t]*=.*/& $(LDFLAGS)/' \
+ Makefile.in || die "Cannot fix LDFLAGS and CPPFLAGS"
+}
+
+src_configure() {
+ local configure_call=(
+ ./configure.sh
+ --libdir="${EPREFIX}"usr/"$(get_libdir)"
+ --prefix="${EPREFIX}"usr
+ --mandir="${EPREFIX}"usr/share/man
+ --shared
+ --pkg-config
+ $(usex minimal '' --enable-all-features)
+ # Enable deterministic HTML generation behavior. Otherwise, will
+ # actually call rand() as part of its serialization code...
+ --debian-glitch
+ )
+ einfo "Running ${configure_call[@]}"
+ CC="$(tc-getCC)" \
+ "${configure_call[@]}" || die
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ $(usex minimal install install.everything) \
+ SAMPLE_PFX="${PN}-"
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins libmarkdown.pc
+}
+
+pkg_postinst() {
+ if ! use minimal; then
+ elog 'Sample binaries with overly-generic names have been'
+ elog "prefixed with \"${PN}-\"."
+ fi
+}
diff --git a/app-text/discount/discount-2.2.3a.ebuild b/app-text/discount/discount-2.2.3a.ebuild
new file mode 100644
index 000000000000..8aa88de24c65
--- /dev/null
+++ b/app-text/discount/discount-2.2.3a.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A Markdown-to HTML translator written in C"
+HOMEPAGE="http://www.pell.portland.or.us/~orc/Code/discount/"
+SRC_URI="http://www.pell.portland.or.us/~orc/Code/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="minimal test"
+
+src_prepare() {
+ default
+
+ # for QA, we remove the Makefile’s usage of install -s.
+ # Drop ldconfig invocation.
+ # Force “librarian.sh” to respect LDFLAGS ($FLAGS should have CFLAGS
+ # at that point).
+ sed -i \
+ -e '/INSTALL_PROGRAM/s,\$_strip ,,' \
+ -e 's/\(LDCONFIG=\).*/\1:/' \
+ -e 's/\(.\)\$FLAGS/& \1$LDFLAGS/' \
+ configure.inc || die "sed configure.inc failed"
+
+ # Add LDFLAGS and CPPFLAGS hackily.
+ sed -i \
+ -e 's/^CC[ \t]*=.*/& $(CPPFLAGS)/' \
+ -e 's/^LFLAGS[ \t]*=.*/& $(LDFLAGS)/' \
+ Makefile.in || die "Cannot fix LDFLAGS and CPPFLAGS"
+}
+
+src_configure() {
+ local configure_call=(
+ ./configure.sh
+ --libdir="${EPREFIX}"usr/"$(get_libdir)"
+ --prefix="${EPREFIX}"usr
+ --mandir="${EPREFIX}"usr/share/man
+ --shared
+ --pkg-config
+ $(usex minimal '' --enable-all-features)
+ # Enable deterministic HTML generation behavior. Otherwise, will
+ # actually call rand() as part of its serialization code...
+ --debian-glitch
+ )
+ einfo "Running ${configure_call[@]}"
+ CC="$(tc-getCC)" \
+ "${configure_call[@]}" || die
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ $(usex minimal install install.everything) \
+ SAMPLE_PFX="${PN}-"
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins libmarkdown.pc
+}
+
+pkg_postinst() {
+ if ! use minimal; then
+ elog 'Sample binaries with overly-generic names have been'
+ elog "prefixed with \"${PN}-\"."
+ fi
+}
diff --git a/app-text/discount/metadata.xml b/app-text/discount/metadata.xml
new file mode 100644
index 000000000000..f5a6787777d1
--- /dev/null
+++ b/app-text/discount/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>reagentoo@gmail.com</email>
+ <name>Dmitry Baranov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>