summaryrefslogtreecommitdiff
path: root/app-text/discount
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /app-text/discount
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'app-text/discount')
-rw-r--r--app-text/discount/Manifest1
-rw-r--r--app-text/discount/discount-2.2.7-r2.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/app-text/discount/Manifest b/app-text/discount/Manifest
index 7b250f418117..266d2a9765d9 100644
--- a/app-text/discount/Manifest
+++ b/app-text/discount/Manifest
@@ -1,4 +1,5 @@
AUX gethopt-undefined.patch 358 BLAKE2B ccc264eece330bc0c8979731410488b070c91e73381ed4f00ff95f04c5f023948f304dd70c0f8ec4ff67abf266d80ce8931fa46f53486e2e0e003f151fbda4b7 SHA512 a7504f3ab60ff49b72e475e558e128522757874d4328abf7e488313dff7c2fc3650fffc12a03109601a14348f24f21a83ed0e83f9d6fe1176207ac2692800dc1
DIST discount-2.2.7.tar.bz2 102277 BLAKE2B 58ec3bce2b8fc41a090d9b81b4326cbf54e36bf774f4f9ef63c2a2b1d34ba464e9f0a021f19b4fef165da426742af3045a631af005371d1a8a4cd81dc0be3367 SHA512 1b61eb7c625bb50da0dbe97350a0ccbb15930ccaef449c4b4659950907bce3c0564dabf20578379a7fdd0e375f5d4d5b61acd34db474a85e942b60373688bd08
EBUILD discount-2.2.7-r1.ebuild 1690 BLAKE2B 710bd40dc677328a0f8aaa6ad3a387d75fe939b289186d889f35002c08c82b52bfaa5fe138816eb7ecdbfd6ec437b863df0c248448cd99e92452a2cafeb995a1 SHA512 27008019ccf6fb42d7e364990baa6facb7f0c8d8e40375dcc44594ccef7c792648f8d1dcd6c69a895c5a059c3799722d43338bbbc1c443dc284433ac0da4156d
+EBUILD discount-2.2.7-r2.ebuild 1696 BLAKE2B cfb7a7bad5acd5e08d4a3600eacdbb6990def006b87e2f86ff8b37495260bddab4ce45871367299575d8d58401e4d52f2db9632d0e40bca04c42e0c64b799728 SHA512 5baf0d566839378f454dbf06b32289c215772f8b4dbaeb97c97869c597a69e49cf03c2393030f918a069b9cacab69e29c7f8908fe8d21298f4703a2f2bbce4e1
MISC metadata.xml 244 BLAKE2B 24ebafa89c32f799b62237b0d9442143de8ccb86c1625f2a49dd91ec9caa63cadc52000005b5b5ef148df89e907e1407330a8d8411ffb5f4facaf629a3184cb8 SHA512 d7a2290eb2970ef7fb9bea275b209c7ace388daadcf3e317b099767d72c7d9f0b894e23492f02e973d27010a7568e48549e4f502c9628efc3133012680304784
diff --git a/app-text/discount/discount-2.2.7-r2.ebuild b/app-text/discount/discount-2.2.7-r2.ebuild
new file mode 100644
index 000000000000..10b47fddbbbe
--- /dev/null
+++ b/app-text/discount/discount-2.2.7-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A Markdown-to HTML translator written in C"
+HOMEPAGE="http://www.pell.portland.or.us/~orc/Code/discount/"
+SRC_URI="http://www.pell.portland.or.us/~orc/Code/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="minimal test"
+RESTRICT="!test? ( test )"
+
+PATCHES=( "${FILESDIR}"/gethopt-undefined.patch )
+
+src_prepare() {
+ default
+
+ # for QA, we remove the Makefile’s usage of install -s.
+ # Drop ldconfig invocation.
+ # Force “librarian.sh” to respect LDFLAGS ($FLAGS should have CFLAGS
+ # at that point).
+ sed -i \
+ -e '/INSTALL_PROGRAM/s,\$_strip ,,' \
+ -e 's/\(LDCONFIG=\).*/\1:/' \
+ -e 's/\(.\)\$FLAGS/& \1$LDFLAGS/' \
+ configure.inc || die "sed configure.inc failed"
+}
+
+src_configure() {
+ local configure_call=(
+ ./configure.sh
+ --libdir="${EPREFIX}/usr/$(get_libdir)"
+ --prefix="${EPREFIX}/usr"
+ --mandir="${EPREFIX}/usr/share/man"
+ --shared
+ --pkg-config
+ $(usex minimal '' --enable-all-features)
+ # Enable deterministic HTML generation behavior. Otherwise, will
+ # actually call rand() as part of its serialization code...
+ --debian-glitch
+ )
+ einfo "Running ${configure_call[@]}"
+ CC="$(tc-getCC)" AR="$(tc-getAR)" \
+ "${configure_call[@]}" || die
+}
+
+src_compile() {
+ emake libmarkdown
+ emake
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ $(usex minimal install install.everything) \
+ SAMPLE_PFX="${PN}-"
+}
+
+pkg_postinst() {
+ if ! use minimal; then
+ elog 'Sample binaries with overly-generic names have been'
+ elog "prefixed with \"${PN}-\"."
+ fi
+}