summaryrefslogtreecommitdiff
path: root/app-text/diff-pdf/diff-pdf-0.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-31 21:24:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-31 21:24:18 +0100
commit6e479260831a77b38f58e3f572ead93d8327cf18 (patch)
tree34d09750ce726569f87a0c559e9f1f843ac3d26b /app-text/diff-pdf/diff-pdf-0.5.1.ebuild
parenta407e25d814596ca802d83102671d95e00079767 (diff)
gentoo auto-resync : 31:05:2023 - 21:24:18
Diffstat (limited to 'app-text/diff-pdf/diff-pdf-0.5.1.ebuild')
-rw-r--r--app-text/diff-pdf/diff-pdf-0.5.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-text/diff-pdf/diff-pdf-0.5.1.ebuild b/app-text/diff-pdf/diff-pdf-0.5.1.ebuild
new file mode 100644
index 000000000000..a02e905054c1
--- /dev/null
+++ b/app-text/diff-pdf/diff-pdf-0.5.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+inherit wxwidgets
+
+DESCRIPTION="A simple tool for visually comparing two PDF files"
+HOMEPAGE="https://vslavik.github.io/diff-pdf/ https://github.com/vslavik/diff-pdf/"
+SRC_URI="https://github.com/vslavik/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+# The COPYING.icons file states that two icons were taken from
+# version 2.16.5 of GTK+, which is licensed LGPL-2+.
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# The build system checks for "poppler-glib", which is provided only
+# when app-text/poppler is built with USE=cairo. Moreover the glib ABI
+# of poppler is relatively stable, and I can only assume that diff-pdf
+# uses that rather than the low-level libpoppler.so API. Since the
+# subslot on app-text/poppler is ONLY for the low-level API, we
+# therefore don't need a subslot dependency on app-text/poppler.
+#
+# Since diff-pdf.cpp includes glib.h directly, I've included
+# dev-libs/glib as an explicit dependency. Ditto for x11-libs/cairo.
+DEPEND="app-text/poppler[cairo]
+ dev-libs/glib
+ x11-libs/cairo
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ setup-wxwidgets
+ default
+}