summaryrefslogtreecommitdiff
path: root/app-text/dictd/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-text/dictd/files
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-text/dictd/files')
-rw-r--r--app-text/dictd/files/dictd-1.13.0-lex.patch28
-rw-r--r--app-text/dictd/files/dictd-1.13.0-libtool.patch59
-rw-r--r--app-text/dictd/files/dictd-1.13.0-version.patch65
3 files changed, 152 insertions, 0 deletions
diff --git a/app-text/dictd/files/dictd-1.13.0-lex.patch b/app-text/dictd/files/dictd-1.13.0-lex.patch
new file mode 100644
index 000000000000..c69758c4805d
--- /dev/null
+++ b/app-text/dictd/files/dictd-1.13.0-lex.patch
@@ -0,0 +1,28 @@
+From: orbea <orbea@riseup.net>
+Date: Sat, 18 Jun 2022 09:10:18 -0700
+Subject: [PATCH] build: Fix implicit function declarations
+
+--- a/clientparse.y
++++ b/clientparse.y
+@@ -24,6 +24,9 @@
+ #define YYERROR_VERBOSE
+
+ static dictServer *s;
++
++int yylex();
++void yyerror(const char *s);
+ %}
+
+ %union {
+--- a/servparse.y
++++ b/servparse.y
+@@ -30,6 +30,9 @@
+
+ static dictDatabase *db;
+
++int yylex();
++void yyerror(const char *s);
++
+ static int string2bool (const char *str)
+ {
+ if (
diff --git a/app-text/dictd/files/dictd-1.13.0-libtool.patch b/app-text/dictd/files/dictd-1.13.0-libtool.patch
new file mode 100644
index 000000000000..f687a182f60f
--- /dev/null
+++ b/app-text/dictd/files/dictd-1.13.0-libtool.patch
@@ -0,0 +1,59 @@
+https://bugs.gentoo.org/818535
+
+From: orbea <orbea@riseup.net>
+Date: Fri, 17 Jun 2022 16:18:40 -0700
+Subject: [PATCH] configure: Add missing LT_INIT
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -28,6 +28,7 @@ endif
+
+ .SUFFIXES:
+
++top_builddir= @top_builddir@
+ srcdir= @srcdir@
+ VPATH= @srcdir@:.
+ prefix= @prefix@
+--- a/configure.in
++++ b/configure.in
+@@ -35,6 +35,8 @@ AC_INIT([dict],[VERSION],[dict-beta@dict.org])
+ AC_CONFIG_SRCDIR([dictd.c])
+ AC_CONFIG_HEADER(config.h)
+
++LT_INIT
++
+ echo Configuring for dict
+ echo .
+
+@@ -70,13 +72,10 @@ echo Checking for programs
+
+ AC_PROG_AWK
+ AC_PROG_INSTALL
+-AC_PROG_RANLIB
+ AC_PROG_MAKE_SET
+ AC_PROG_YACC
+ AC_PROG_LEX
+
+-AC_CHECK_PROG(LIBTOOL,libtool,libtool)
+-
+ AC_CHECK_PROGS(NROFF,gnroff nroff)
+ AC_CHECK_PROGS(TROFF,groff troff)
+ AC_CHECK_PROGS(COL,col cat)
+@@ -188,7 +187,6 @@ AC_SUBST(DICT_VERSION)
+ AC_SUBST(USE_PLUGIN)
+ AC_SUBST(EXEEXT)
+ AC_SUBST(allsubdirs)
+-AC_SUBST(LIBTOOL)
+
+ AC_SUBST(PLUGINS)
+
+--- a/doc/Makefile.in
++++ b/doc/Makefile.in
+@@ -28,6 +28,7 @@ endif
+
+ .SUFFIXES:
+
++top_builddir= @top_builddir@
+ srcdir= @srcdir@
+ VPATH= @srcdir@
+ prefix= @prefix@
diff --git a/app-text/dictd/files/dictd-1.13.0-version.patch b/app-text/dictd/files/dictd-1.13.0-version.patch
new file mode 100644
index 000000000000..fee60efe22da
--- /dev/null
+++ b/app-text/dictd/files/dictd-1.13.0-version.patch
@@ -0,0 +1,65 @@
+https://bugs.gentoo.org/852884
+
+From: orbea <orbea@riseup.net>
+Date: Sat, 18 Jun 2022 10:00:21 -0700
+Subject: [PATCH] configure: Set version directly in AC_INIT
+
+This avoids a command not found error in config.status.
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -20,7 +20,7 @@
+
+ # Add a _letter_ if you change the version number and release your own version.
+ # Numbers are for the original author(s) only.
+-DICT_VERSION=@DICT_VERSION@
++DICT_VERSION=@PACKAGE_VERSION@
+
+ ifneq (,)
+ This makefile requires GNU Make.
+--- a/configure.in
++++ b/configure.in
+@@ -23,14 +23,10 @@ dnl CFLAGS and LDFLAGS should be settable on the make commandline
+ dnl for optimization and stripping.
+ dnl LIBOBJS is an automatically-generated list of extra objects we need
+
+-
+-define(VERSION, 1.13.0)
+-
+-
+ AC_PREREQ(2.53)
+ AC_REVISION($Revision: 1.144 $)
+
+-AC_INIT([dict],[VERSION],[dict-beta@dict.org])
++AC_INIT([dict],[1.13.0],[dict-beta@dict.org])
+
+ AC_CONFIG_SRCDIR([dictd.c])
+ AC_CONFIG_HEADER(config.h)
+@@ -40,8 +36,6 @@ LT_INIT
+ echo Configuring for dict
+ echo .
+
+-DICT_VERSION=VERSION
+-
+ AC_CANONICAL_HOST
+
+ AC_PROG_CC
+@@ -183,7 +177,6 @@ SBINDIR=`eval3 $sbindir`
+ LIBEXECDIR=`eval3 $libexecdir`
+ DATADIR=`eval3 $datadir`
+
+-AC_SUBST(DICT_VERSION)
+ AC_SUBST(USE_PLUGIN)
+ AC_SUBST(EXEEXT)
+ AC_SUBST(allsubdirs)
+--- a/dictdplugin-config.in
++++ b/dictdplugin-config.in
+@@ -24,7 +24,7 @@ while test $# -ne 0; do
+ usage
+ exit;;
+ --version)
+- echo @DICT_VERSION@
++ echo @PACKAGE_VERSION@
+ exit;;
+ --libs)
+ echo -L@libdir@