summaryrefslogtreecommitdiff
path: root/app-text/delta
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/delta
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/delta')
-rw-r--r--app-text/delta/Manifest3
-rw-r--r--app-text/delta/delta-20060803.ebuild34
-rw-r--r--app-text/delta/metadata.xml14
3 files changed, 51 insertions, 0 deletions
diff --git a/app-text/delta/Manifest b/app-text/delta/Manifest
new file mode 100644
index 000000000000..a54df42bcdbb
--- /dev/null
+++ b/app-text/delta/Manifest
@@ -0,0 +1,3 @@
+DIST delta-2006.08.03.tar.gz 32804 BLAKE2B 6e070aea4e9bb4ef849fb0e193cdef08771e74bcd46219bc380f58219d05d2c73ab0738a2d611e3c2bce72a92b82276ec4b8c741f33f092dc348acb153aaa6f4 SHA512 3720f164f3721ad06bf5a73e654c70a67d6e7a56d0ce574fb0e8571b33269e56611a909f915bd0ea46434d94206a9548fd99fdef98181efe41e7fb03de75c585
+EBUILD delta-20060803.ebuild 733 BLAKE2B af281539bd837c7b5457a03381cd2ce9118fa2e8517b50aad87b9980b8d8099f10135e6aa7739e22836b6fff69c8e60add2dc93bf82f190afe0bc1d9cf31525d SHA512 0341224ebe9e298fefddefba786bd686731d13c105b36ecd1cb9f7c37966b4813ae9bb154b286f3ad3a64a8812d012463feffeb58e76144438ad57126fe3d7fb
+MISC metadata.xml 553 BLAKE2B 9cda4f71d8e01943e664d2802e9c048a200cb7d6b171d99cfbf42fb9578b48600506130571b030bc4ef001d2c898727f2c69330049425d84a9e74b2634c7dd92 SHA512 c85367dc67630d0879e88dbc93b73f7283f1dd526a03a7c44eaba69556d69c5c60f5b0c187daf05f05a90d6ae644c1a72ce47ab5a6fe8ec46e92a827f0f1c9b4
diff --git a/app-text/delta/delta-20060803.ebuild b/app-text/delta/delta-20060803.ebuild
new file mode 100644
index 000000000000..59243222f2a5
--- /dev/null
+++ b/app-text/delta/delta-20060803.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+MY_PV="${PV:0:4}.${PV:4:2}.${PV:6:2}"
+STUPID_NUM="33566"
+DESCRIPTION="Heuristically minimizes interesting files"
+HOMEPAGE="http://delta.tigris.org/"
+SRC_URI="http://delta.tigris.org/files/documents/3103/${STUPID_NUM}/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ppc ppc64 s390 sh sparc x86 ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND=""
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_compile() {
+ rm -f Makefile
+ tc-export CC
+ emake topformflat
+}
+
+src_install() {
+ dobin delta multidelta topformflat
+ dodoc Readme
+ dohtml www/*
+}
diff --git a/app-text/delta/metadata.xml b/app-text/delta/metadata.xml
new file mode 100644
index 000000000000..493b7194651e
--- /dev/null
+++ b/app-text/delta/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>toolchain@gentoo.org</email>
+ <name>Gentoo Toolchain Project</name>
+ </maintainer>
+ <longdescription>
+ Delta assists you in minimizing "interesting" files
+ subject to a test of their interestingness. A common such situation
+ is when attempting to isolate a small failure-inducing substring of
+ a large input that causes your program to exhibit a bug.
+ </longdescription>
+</pkgmetadata>