summaryrefslogtreecommitdiff
path: root/app-text/crwx-ng/crwx-ng-0.2.0-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-29 21:18:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-29 21:18:33 +0100
commit63a4617476a3b084928b38d816b9ed6e196d62f5 (patch)
treef1c7e30e8c9b33d9f7e7b0a2e3dbd1d1121358c4 /app-text/crwx-ng/crwx-ng-0.2.0-r4.ebuild
parent662f71ae67cd775d7fbb79b5091676c0e07a992b (diff)
gentoo auto-resync : 29:05:2023 - 21:18:33
Diffstat (limited to 'app-text/crwx-ng/crwx-ng-0.2.0-r4.ebuild')
-rw-r--r--app-text/crwx-ng/crwx-ng-0.2.0-r4.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-text/crwx-ng/crwx-ng-0.2.0-r4.ebuild b/app-text/crwx-ng/crwx-ng-0.2.0-r4.ebuild
new file mode 100644
index 000000000000..1042a5a774a0
--- /dev/null
+++ b/app-text/crwx-ng/crwx-ng-0.2.0-r4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+WX_GTK_VER="3.2-gtk3"
+inherit cmake wxwidgets
+
+DESCRIPTION="Cross-platform e-book reader"
+HOMEPAGE="https://gitlab.com/coolreader-ng/crwx-ng"
+SRC_URI="https://gitlab.com/coolreader-ng/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gif +svg +chm +harfbuzz +libunibreak +fribidi +zstd +libutf8proc"
+
+CDEPEND=">=app-text/crengine-ng-0.9.7:0=[png,jpeg,fontconfig,gif=,svg=,chm=,harfbuzz=,fribidi=,zstd=,libutf8proc=]
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+BDEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}
+ virtual/ttf-fonts"
+
+PATCHES=( "${FILESDIR}"/${P}.patch )