summaryrefslogtreecommitdiff
path: root/app-text/crf++/crf++-0.58.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-text/crf++/crf++-0.58.ebuild
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/crf++/crf++-0.58.ebuild')
-rw-r--r--app-text/crf++/crf++-0.58.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/app-text/crf++/crf++-0.58.ebuild b/app-text/crf++/crf++-0.58.ebuild
deleted file mode 100644
index c358043e7e8e..000000000000
--- a/app-text/crf++/crf++-0.58.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit autotools
-
-MY_P="${P^^[crf]}"
-
-DESCRIPTION="Yet Another CRF toolkit for segmenting/labelling sequential data"
-HOMEPAGE="https://taku910.github.io/crfpp/"
-SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
-
-LICENSE="|| ( BSD LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="amd64 x86 ~x86-fbsd"
-IUSE="examples static-libs"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=( "${FILESDIR}"/${PN}-automake-1.13.patch )
-HTML_DOCS=( doc/. )
-
-src_prepare() {
- sed -i \
- -e "/CFLAGS/s/-O3/${CFLAGS}/" \
- -e "/CXXFLAGS/s/-O3/${CXXFLAGS}/" \
- configure.in
-
- default
- mv configure.{in,ac} || die
- eautoreconf
-}
-
-src_configure() {
- econf $(use_enable static-libs static)
-}
-
-src_test() {
- local d
- for d in example/*; do
- cd "${d}"
- ./exec.sh || die "failed test in ${d}"
- cd - >/dev/null
- done
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- einstalldocs
-
- if use examples; then
- docompress -x /usr/share/doc/${PF}/example
- insinto /usr/share/doc/${PF}
- doins -r example
- fi
-
- if ! use static-libs; then
- find "${ED}" -name "*.la" -type f -delete || die
- fi
-}