summaryrefslogtreecommitdiff
path: root/app-text/cpdf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/cpdf
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/cpdf')
-rw-r--r--app-text/cpdf/Manifest3
-rw-r--r--app-text/cpdf/cpdf-2.1.1-r1.ebuild41
-rw-r--r--app-text/cpdf/metadata.xml11
3 files changed, 55 insertions, 0 deletions
diff --git a/app-text/cpdf/Manifest b/app-text/cpdf/Manifest
new file mode 100644
index 000000000000..8ae7aacab42b
--- /dev/null
+++ b/app-text/cpdf/Manifest
@@ -0,0 +1,3 @@
+DIST cpdf-2.1.1.tar.gz 349536 BLAKE2B 4064605890745ebaa24d32c3294a3293312dc8df6ab3989e1a7417989cdb19aca6b70faafb258c7c00d6febeba8b17379396c1f90628e72be0791cdefc579b6f SHA512 aa06efaf098d3fe3f560ea30da9c3546e13d294b22d61c4cc3df553eb90e338d59ee1b51d14d7982ce52967bcf98c2afec9a5b5ae101e2183961f4be862c6517
+EBUILD cpdf-2.1.1-r1.ebuild 815 BLAKE2B e3db88ff54d34fe7b74bb9bda9496dbc20a992bb4b50a0ff537ab7cb871cdb08bf55d57967f4ae2810ad5dd34dd5df5c9ec52665532d2b374c082bd9c1c74e61 SHA512 e51916639a09447f6cefa7d2400c0ea1349f52926acd16b6d4ef250c5a4d865af04501763e0f0d40d78735e426b601c8d88cf171d2cff374898b6b98a3c8fff8
+MISC metadata.xml 347 BLAKE2B 2f11a4f77be2b5501b6789daa1724cb1933313963450fa1df91072c095cab406f3907bb2656715022ffff4be94e6b8f4e70d5beae1feeb3b3fd5a2fa1c8413a1 SHA512 e97b4580d3d0e3c06a6e24aac842e66a354e2a9ea9eb70486383143999a2c8a188bdc5ac2d5672ae1ed83950f94d8fcce3d8c3a4d701009bd4102b88bd4b715d
diff --git a/app-text/cpdf/cpdf-2.1.1-r1.ebuild b/app-text/cpdf/cpdf-2.1.1-r1.ebuild
new file mode 100644
index 000000000000..74a530638f33
--- /dev/null
+++ b/app-text/cpdf/cpdf-2.1.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="A command line tool for manipulating PDF files"
+HOMEPAGE="http://community.coherentpdf.com/ https://github.com/johnwhitington/cpdf-source/"
+SRC_URI="https://github.com/johnwhitington/cpdf-source/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# BSD is only for xmlm.ml
+LICENSE="Coherent-Graphics BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/ocaml-4:=
+ dev-ml/camlpdf:="
+DEPEND="${RDEPEND}"
+
+RESTRICT="mirror bindist"
+
+S=${WORKDIR}/${PN}-source-${PV}
+
+src_compile() {
+ # parallel make issues
+ emake -j1
+}
+
+src_install() {
+ findlib_src_install
+
+ dobin cpdf
+ dodoc Changes README.md
+
+ if use doc ; then
+ dodoc cpdfmanual.pdf
+ dohtml doc/cpdf/html/*
+ fi
+}
diff --git a/app-text/cpdf/metadata.xml b/app-text/cpdf/metadata.xml
new file mode 100644
index 000000000000..86681fac3204
--- /dev/null
+++ b/app-text/cpdf/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">johnwhitington/cpdf-source</remote-id>
+ </upstream>
+</pkgmetadata>