summaryrefslogtreecommitdiff
path: root/app-text/chasen/chasen-2.4.4-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/chasen/chasen-2.4.4-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/chasen/chasen-2.4.4-r3.ebuild')
-rw-r--r--app-text/chasen/chasen-2.4.4-r3.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/app-text/chasen/chasen-2.4.4-r3.ebuild b/app-text/chasen/chasen-2.4.4-r3.ebuild
new file mode 100644
index 000000000000..918861f19523
--- /dev/null
+++ b/app-text/chasen/chasen-2.4.4-r3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils perl-module
+
+DESCRIPTION="Japanese Morphological Analysis System, ChaSen"
+HOMEPAGE="http://chasen-legacy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/chasen-legacy/32224/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86 ~sparc-solaris"
+IUSE="perl static-libs"
+
+DEPEND=">=dev-libs/darts-0.32"
+RDEPEND="${DEPEND}
+ perl? ( !dev-perl/Text-ChaSen )"
+PDEPEND=">=app-dicts/ipadic-2.7.0"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cve-2011-4000.patch
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+ if use perl ; then
+ cd "${S}"/perl
+ perl-module_src_configure
+ fi
+}
+
+src_compile() {
+ default
+ if use perl ; then
+ cd "${S}"/perl || die
+ perl-module_src_compile
+ fi
+}
+
+src_test() {
+ default
+ if use perl ; then
+ cd "${S}"/perl || die
+ perl-module_src_test
+ fi
+}
+
+src_install () {
+ default
+
+ if use perl ; then
+ cd "${S}"/perl || die
+ perl-module_src_install
+ newdoc README README.perl
+ fi
+
+ prune_libtool_files
+}